Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a lenovo G430 machine with ubuntu 12.04 running on it. The Network configuration is DHCP, It gets the IP but fails to get the DNS and henceforth wont be able to browse internet.The issue is only with this machine as all the other machine's in the network is able to connect and browse fine.

share|improve this question
    
How do you set up your network connection? Do you use some application like "networkmanager" or "wicd"? If so, are you sure that it is set to get DNS server address automatically and not just the IP address? –  AcId May 20 '13 at 9:23
    
@AcId I use a networkmanager for managing the connections. How do i set it to receive dns ? i have just given the DHCP in network settings. –  rahul May 20 '13 at 12:28
    
In networkmanager, when you edit the connection, under the IPv4 Settings tab, the method should be Automatic(DHCP) and NOT Automatic(DHCP) addresses only. If this is allready the case, I don't know why it doesn't get DNS info, when it works for other PCs on the same network. You could try and set some DNS server manually e.g. (8.8.8.8) and (8.8.4.4) for Google DNS. –  AcId May 20 '13 at 12:36
    
If the connection i wired, you could also try setting up the connection manually with ifconfig. If you're network controller is named eth0: First disable networkmanager, then, as root run ifconfig eth0 up followed by dhcpcd eth0, and see if this makes any difference. It gets a bit more compicated with a wireless interface, because you have to associate with the AP first. –  AcId May 20 '13 at 14:27
    
@AcId Its already on Automatic(DHCP) as you have mentioned. and if i have to set manually, that is a pain setting it manually every day. Anyways thank you for the inputs. –  rahul May 21 '13 at 5:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.