Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Office 2010 running on Windows 7, I have a hyperlink in Excel to a JPG on a drive:

=HYPERLINK("\\myserver\dir1\file.jpg", "Link")

The problem: when clicked in Excel, this link ONLY opens in Internet Explorer, and I would like to change it to another application such as Windows Photo Viewer or Irfan.

I have found suggestions to do the following, none of which work:

  1. Change the default open-with application in Explorer (right-click, open-with, etc);
  2. Add a new DWORD key to the registry with ForceShellExecute=1 (apparently does not work with Win7).

Any ideas?

share|improve this question
    
As an aside: even when using another default browser (like Firefox, Chrome), then for internet URLs Excel always first uses an Internet Explorer component to determine what to do. (Microsoft Office Protocol Discovery.) If that component is used for ALL hyperlinks, maybe the setting you need is somewhere in IE, not in Excel. (But then: I guess you don't want IE to start Irfan when browsing images on a website...) –  Arjan May 20 '13 at 7:29
    
@Arjan - corrected my HYPERLINK formula; originally thought you were referring to the second variable. –  Simbamangu May 29 '13 at 13:38
add comment

2 Answers 2

Add a new key to the registry:

  1. Go to HKEY_CLASSES_ROOT\jpegfile\CLSID
  2. Right-click on (Default) and select Modify
  3. Enter the value {FFE2A43C-56B9-4bf5-9A79-CC6D4285608A}

This will now change the open-with behaviour in MS Excel 2010 to use the default Windows app. Confirmed to work with Excel 2010 and Windows 7.

Surely there is a more elegant solution, though?

share|improve this answer
add comment

You can simply go the settings of the web browser you would like to be your default web browser. Select it as the default web browser. Then your new default web browser will be used for opening up hyperlinks etc.

i.e. In Chrome you can select the Customize and Control button on the top right hand side of the browser, select Settings, and under the Default browser select make Google Chrome my default web browser.

share|improve this answer
    
The user doesn't want to open the file in a different browser, they want to open the file in a different application. –  Josh R Sep 6 '13 at 16:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.