Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I downloaded VLC on my CentOS 6.

When I play a video by double clickig on finder, or using the vlc command in terminal, it shows a black screen. Sound works fine though.

Do you have any idea what could cause this problem?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Actually I solved with options, not code.

Tools --> preferences --> Video

and uncheck Accelerated video output(Overlay).

:D So simple;;

share|improve this answer

You probably just need to install some codecs. Try this:

yum -y --enablerepo=rpmforge install compat-libstdc++-33  \
 libdvdcss libdvdread libdvdplay libdvdnav lsdvd libquicktime \ 
 gstreamer-ffmpeg gstreamer-plugins-good gstreamer-plugins-bad \ 
 gstreamer-plugins-ugly

Also check that you have the right output module chosen in vlc's preferences:

enter image description here

Depending on your setup and what kind of desktop/desktop effects you have enabled you may need to use a different output module, try a few.

share|improve this answer
    
Thanks for your answer, but I could not make it work. I installed codecs. And I am really new in multi media and linux, so can you tell me little more details about VLC video settings? Maybe I need some more packages? –  Juneyoung Oh May 21 '13 at 2:19
    
I have installed all of thing you mentioned, ans it still does not work:( I found some articles which has same content with my questions, but none of them has correct answer. It makes me crazy. Is there any chance to fix this? –  Juneyoung Oh May 23 '13 at 6:43
    
I got answer here. I hate this program....forums.opensuse.org/english/get-technical-help-here/multimedia/… –  Juneyoung Oh May 23 '13 at 7:04
    
@JuneyoungOh what did you actually do? If my answer did not solve your problem don't mark it as accepted, instead post the solution that worked for you as an answer and accept that. –  terdon May 23 '13 at 11:30
    
OK.Sorry. I just want to close this question;; And Actually what I did is just unchecking Accelerated video output(Overlay). Thanks for your advise and I'll fix it immediately –  Juneyoung Oh May 24 '13 at 2:20

My VLC version is 2.0.5 just installed with CentOS6.4. My problem was no sound and or picture.

To get sound I did as advised:

  1. Tools > Preferences > Video

  2. Uncheck Accelerated video output (Overlay).

To get video:

  1. Tools > Preferences > Video
  2. Change video output to X11 video output (XCB).
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.