Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I boot windows, media player classic starts running in the background (no actual MPC window opens) and hogs the CPU at 100% until I kill it. In process explorer the parent is explorer. I was wondering what could be causing this as I cannot find it under startup in msconfig.

Versions:

Windows 7 64bit Windows Media Player Classic x64 - 1.6.1.4235

share|improve this question
    
make an update to Media Player Classic Home Cinema 1.6.7.7114 and if this doesn't fix it, capture a xperf trace and upload the zipped ETL file: msfn.org/board/index.php?showtopic=140264 –  magicandre1981 May 20 '13 at 18:04
1  
use Autoruns from sysinternals to determine how the process is being started. technet.microsoft.com/en-us/sysinternals/bb963902.aspx –  Frank Thomas May 20 '13 at 18:25
    
@FrankThomas It is not listed! I do not see it anywhere... The interesting thing is that I have completely uninstalled mpc deleted the program folder and it still runs at startup! –  Isopycnal Oscillation May 20 '13 at 18:43
    
@magicandre1981 So I completely removed the program and rebooted, and it still runs at startup! The path is not the same path, it is running under flash player \AppData\Roaming\Adobe\Flash Player\SpeedCache\ –  Isopycnal Oscillation May 20 '13 at 18:44
1  
I think this would now quality as a duplicate of A malicious threat was detected in Media Player Classic exe file, since it wasn't Media Player Classic, but a virus... –  Breakthrough May 25 '13 at 5:21

2 Answers 2

up vote 1 down vote accepted

I don't know why I can't post comments, but have you tried deleting the mpc executable from \AppData\Roaming\Adobe\Flash Player\SpeedCache\?

If the file runs in the cache of Flashplayer, you can also try to clean that cache with CCleaner

You can also try to install it again, and then Uninstall with an uninstaller tool like Revo. It will scan your computer after uninstall for any leftovers of the program so you can delete them.


You can also search for more startup locations with Startup CPL. Hopefully you can see your mpc.exe listed somewhere.

share|improve this answer
    
I think you can't comment because there is a minimum of 50 reputation. Yes I removed it and now I get the "windows cannot find..." error at startup. I am trying to figure out what is issuing that command but cant find it in the startup list –  Isopycnal Oscillation May 20 '13 at 19:28
    
Hmm.. This tool displays startup items from several locations: startup CPL. Hopefully it will find your mpc startup registry. If not I recommend you to install it again and try Revo Uninstaller (see above). With that you can make sure all leftovers from the program are removed from your system. –  Forza May 20 '13 at 21:39
    
If you want, you can also try to search for mpchc64.exe in the register itself. Type regedit.exe in the start or run menu and open the registry editor. Press ctrl+F and search for mpchc64. If it finds anything, check if the key name you are browsing ends with "\Run". These are locations that specificy which programs run at boot. If you find an mpchc64 entry in a "\Run key, delete it. Make sure to create a backup of your registry if all this is new for you. –  Forza May 20 '13 at 21:45
    
The startup tool looked promising, but I do not see any reference to MPC anywhere... I had already tried to first uninstall using revo and then searched the registry for any mention of mpc and there was nothing. Thats what's crazy about it, after uninstalling fully, it was still running at startup from the flash player folder mentioned in the question. –  Isopycnal Oscillation May 20 '13 at 23:08
    
Hmm that's crazy indeed :) I'm running a bit out of options now. You have deleted flash player cache with ccleaner, right? What you can try is to create a new user account. Then login with that one and see if it gives the error message. If it doesn't, then you can use that account instead. That is better than reinstalling windows for such a weird issue. If anyone else know something you can try, they are welcome to give some input here. –  Forza May 21 '13 at 12:19

Delete all files in C:\Users\(UserName)\AppData\Roaming\Adobe\Flash Player\SpeedCache.

Remove the SpeedUpSystem registry entry from: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.