Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My friend convinced me to allow him to change some of my key bindings.

Friend: "How often do you use Caps Lock?"

Anyway, now when I want to perform a newline without submitting a form, I have to do Caps Lock+Return instead of Shift+Return. This is very annoying because it turns Caps Lock on/off each time.

I have attempted to restore all defaults, but it doesn't seem to work. I'm going to restart again and hopefully that works, but I am beginning to doubt anything is going to work.

What am I missing here? How am I breaking this? I must be doing something very dumb but I can't see it. How can I change my settings back to the point where Shift+Return does what it used to?

share|improve this question

closed as not constructive by Oliver Salzburg May 20 '13 at 18:34

As it currently stands, this question is not a good fit for our Q&A format. We expect answers to be supported by facts, references, or expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, visit the help center for guidance.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Ask your friend –  Oliver Salzburg May 20 '13 at 18:34
    
I did, he tried and failed to fix it. –  Kyra Westwood May 20 '13 at 18:49
    
So he's even unable to tell you how he changed it in the first place? –  Oliver Salzburg May 20 '13 at 18:53
    
He said that he went to Settings -> Keyboard -> Modifier Keys, then changed Caps Lock Key: to Control and Control Key: to Caps Lock. He did these for both of my keyboards. I went restored defaults for both of my keyboards, but my shift key still doesn't seem to work. It works for his setup, which leads me to suspect that some other action was performed that I do not know of (which led me to ask my question). –  Kyra Westwood May 20 '13 at 18:58
    
It has been fixed! I don't understand how, but it magically is fixed now! (I'll accept Andrea's answer because it is relevant) –  Kyra Westwood May 20 '13 at 19:02

1 Answer 1

up vote 1 down vote accepted

I found an article on macRumors that fits your question:

Changing Keyboard Shortcuts

All you need to do is:

System preferences > Keyboard > Shortcuts pane

Look for the section you are interested to, and change it.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.