Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I ran "yum install ImageMagick" on our CentOS 6.3 server, which worked fine, but identify -version and convert don't work (-bash: /usr/local/bin/identify: No such file or directory).

I originally installed it through source based on ImageMagick.org's instructions (they said to do this if I didn't have a supported OS version, and theirs was only up to CentOS 5.8). That installed fine (though it was missing delegates so I figured it would be faster to just uninstall and try it through yum). I have no idea the proper way to fix this and I'm not sure if installing from source screwed something up. Do I just need to set paths or something?

share|improve this question
    
I did notice that identify is in /usr/bin... not sure how to get it to point back to there for that. It should be checking both I suppose. – user2344668 May 20 '13 at 20:54
up vote 0 down vote accepted

Do a “hash -r” in your shell to clear the path cache. Your shell keeps the path to previously used commands to avoid seeking directories endlessly; it's a good thing, but what you stumbled upon is one of the rare instances where that mechanism fails.

share|improve this answer
    
That worked! Thank you! – user2344668 May 21 '13 at 1:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .