Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a cable to replace my old one, connecting my laptop to a monitor Philips 170s. It is a VGA port on the computer and monitor.

Unfortunately, even though it works, I get some fuzz (noises) in the screen that do not disappear by "playing" with the cable. Is there any setting to change for this, or is it a faulty cable?

Here are the specs:

  • VGA to SVGA Male
  • High quality HD15 Male-to-Male Super S-VGA Cable for your monitor/LCD
  • Supports VGA, SVGA, XGA, XGA+, SXGA, SXGA+, UXGA.

enter image description here

share|improve this question
    
At the time that you changed the cable, have you put some new electrical device near the computer/monitor/cable that may generate intense electrical fields? –  harrymc Jun 12 '13 at 20:50
1  
There is no setting to make the signal more reliable. The maximum amount of reliability possible is already built into the signalling standard. –  David Jun 14 '13 at 20:58
add comment

7 Answers

The cited "specs" of your cable are only advertising words. It is usually difficult to get specifications (loss, shielding, capacity, ...) of a cheap cable. Some cables use a ferrite cylinder increase the inductivity of the cable. This helps to suppress high frequency noise. May be the "chirp" vanishes, if you use a ferrite.

Check if both cables used a ferrite choke as shown in this Wiki Commons picture enter image description here

share|improve this answer
    
+1 for shielding; if the video cable isn't shielded and running parallel to a un-shielded power cable, lots of weird things could turn up. –  panhandel Jun 13 '13 at 4:36
    
As @panhandel says, make sure that it's not by a power cable, the cheaper cables are quite sensitive to being near power cables. –  David Jun 14 '13 at 20:56
add comment

If a previous cable worked fine and the new one has issues, then the straight-forward and logical conclusion is that the problem is with the cable.

In your place I would ask for a replacement, if at all possible.
Or if the problem persists, invest in a better-quality cable.

share|improve this answer
    
agreed. still make sure all cables are securely in place. Miight not hurt to reseat the graphics card as well. –  Keltari Jun 12 '13 at 18:35
add comment

Depending on your display, it could be either.

When I come across an LCD monitor that's fuzzy, I generally give it a few good smacks (seriously) around the edges to see if that makes it better. If it does, even for a really short amount of time, it is usually possible to take apart the monitor and reseat some of the connections and give it another shot.

If hitting the monitor does not fix anything, it is likely the cable; if you have other monitors available to you, or other computers, you should try them in different combinations to see if you can narrow down the source of the problem. I've never actually encountered a vga cable that causes fuzziness; it's generally one of the devices. But if the cable is extremely low quality, I suppose it could.

share|improve this answer
add comment

It sounds like a faulty cable, check your pins and and the VGA connections for both the monitor and the PC. You may have something on the pins or in the connections. Short of that have you tried a different cable to see if it also displays this problem. If you did not have the issue before and you do now with a new cable, it is more than likely the cable.

share|improve this answer
add comment

Some VGA/SVGA cables have a slightly different frequency affinity than others, so when changing them out, I often will hit the "auto" button or menu option on the monitor to get it to re-scan the incoming signal and to pick up the best clock timing and sync for the resolution for that screen.

This may or may not apply to the problem you're having, but it has solved problems with fuzzy areas on some systems when I changed out VGA/SVGA cables.

Cables that are DVI and better don't exhibit these problems because they're digital, and not analog.

share|improve this answer
add comment
  1. connect the cable to another monitor and check whether the issue is still there
  2. check continuity of the cable
  3. check whether the signal from laptop is not weak, check it by connecting it to another monitor
  4. check your inverter circuitry and power supply unit in your monitor to ensure that nothing is wrong.
  5. check whether cable can be properly inserted at both the sides.
  6. Ensure that, there is no external disturbance such as electric cable, Speaker systems etc
  7. Ensure cable is not twisted or folded
share|improve this answer
add comment

One option is to make sure you get a cable with thick ferrite beads. The ferrite beads help reduce noise on the cable, generally the bigger they are the better. I often find when I have display issues with VGA cables switching to one with bigger ferrite beads resolves the problem. Neither of the cables in your picture have ferrite beads on them. I would suggest you check out the VGA cables from Monoprice.com. They are excellent quality (at least I've never had any issues and I have purchased a bunch of them), and they are very cheap.

share|improve this answer
    
Why the downvote? –  druciferre Jun 15 '13 at 0:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.