Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

1 CPU: AMD FX-8150 Zambezi 3.6Ghz Socket AM3+ 125W 8-core RAM: CORSAIR Vengeance LP 16Gb (4x4Gb) 240-Pin DDR3 SDRAM 1866 CML16GX3M4A1866C9B Mobo: ASUS M5A97 LE R2.0 AMD 970 PSU: Thermaltake TR2 TR-5000 500W ATX12V v2.3 GPU: ASUS 210-SL-512MD3-L GeForce 210 512MB(TC 1GB DDR3) 32-bit DDR3 PCI Express 2.0x16 SATA: 2 x Seagate Barracuda ST31000524AS 1TB 7200 RPM 32MB SATA 6.0Gb/s 3.5" Internal Hard Drivw

I have assembled this system myself for my webserver. However, I am experiencing problems with RAID array configurations in UEFI BIOS. Fedora 18 has a known bug, hence I switched to Ubuntu server 13.04 (64-bit). However, even Ubuntu fails to install. Here's what I did:

Configure SATA ports 1-4 as RAID (both hard drives are in those ports) Configure SATA ports 5-6 as IDE (SATA DVD Drive) RAID ROM Controller as Legacy Rom (UEFI option seems bugged or I have no clue how to configure it, even though I select Storage boot option as UEFI driver first)

Reboot the sytem

Configure RAID in legacy interface (CTRL + F) and set up RAID 1 array with Initialization: Full, and the rest are default settings (Read Ahead, etc)

Then I put Ubuntu Server ISO and do the installation with RAID settings that Ubuntu detects...

When installer finishes - nothing is hapenning, except UEFI sees Ubuntu with UEFI label on it, but after the POST it says that no bootable disk is found and etc.

I have tested RAM with Memtest86+ and it passed. I have installed Windows 7 on both Hard drives just to check if hard drive is bad, turns out - not. PSU was tested with my Coolmax PSU tester. Hence, hardware is not at fault, except that UEFI (my suspicion). However, I have upgraded it to the latest version 1709 (http://ca.asus.com/en/Motherboards/AMD_AM3Plus/M5A97_LE_R20/#download) UEFI is by American Megatrends, Inc version 2.10 - but no help at ami.com

I am lost here...

Why UEFI driver for RAID does not work on the mobo? Why Ubuntu Server reports that it is installed in UEFI, but I cannot load into it after POST?

Any help? Has anyone actually set up a RAID1 array with UEFI driver? And what linux distro worked?

I cannot believe that Windows 7 has no problems flying on this hardware...

share|improve this question

migrated from stackoverflow.com May 21 '13 at 1:03

This question came from our site for professional and enthusiast programmers.

    
Welcome to StackOverflow. This site is for programming (code) and programmers tools related questions, not general computer or operating system questions. The faq has more information about the types of questions that are appropriate to ask here. Voting to close as off topic and migrate to AskUnbuntu, where it's more appropriate. Good luck. –  Ken White May 21 '13 at 1:00
    
Wouldn't it be simpler not to use the on-board software RAID but to use mdadm instead? –  Hennes May 21 '13 at 5:47

1 Answer 1

UEFI cannot boot from a RAID array.

Believe me, I've tried. You need a dedicated FAT32 partition to host the EFI shell and boot files, and this partition cannot be part of any RAID.

As redundancy you can simply dd the partition to another device then configure the EFI boot manager to point to the second as backup, but once it's marked by the RAID superblock EFI can't read it (EFI can only read unmarked FAT partitions).

share|improve this answer
    
In that case, can you use an USB pendrive (or something similar like a CF card, SDcard in a reader, eSATA pendrive, old laptop HDD, ...) as a boot device? –  Hennes May 29 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.