Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 10" touch screen for a Raspberry Pi, but the CD along with the touch controller supports only Windows CE, Fedora, SUSE and Red Hat. I tried SUSE and Fedora. The files were in script format, .sh.

I tried chmod +x, then sh, and I got this error:


: not 2: 
: not 3: :
: not 4: :
: not 6: :
: not 8: :
: not 9: :
: not 10: :
: not 11: :
: not 16: 1: 
Syntax error: word unexpected (expecting ")")

For Fedora:

bash: ./ /bin/sh^M: bad interpreter: No such file or directory

I need it for Wheezy, what should I do?

share|improve this question

1 Answer 1

The drivers will almost certainly be x86 specific and not usable on the Pi's ARM processor.

It'd probably be worth asking around on the rPi forums to see if anyone has had any luck, or check the wiki to see if its listed as supported.

I'm assuming you've plugged it in though to see if it 'just works', which it may well do.

You should also take a look at

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.