Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a 10 inch touch screen for a Raspberry Pi, but the CD along with the touch controller supported only Win CE, Fedora, Suse, Redhat. I tried Suse and Fedora; the files were in script format, .sh.

I tried chmod +x, then sh touchkit.setup_Suse90.sh, and I got this error:

For Suse:

sh touchkit.setup_suse90.sh 
: not foundtup_suse90.sh: 2: touchkit.setup_suse90.sh: //
: not foundtup_suse90.sh: 3: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 4: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 6: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 8: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 9: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 10: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 11: touchkit.setup_suse90.sh: ://
: not foundtup_suse90.sh: 16: touchkit.setup_suse90.sh: //
touchkit.setup_suse90.sh: 1: touchkit.setup_suse90.sh: Syntax error: word unexpected (expecting ")")//

For Fedora:

bash: ./touchkit.setup_fdr.sh: /bin/sh^M: bad interpreter: No such file or directory//

But I need it for Wheezy… what should I do?

share|improve this question

migrated from stackoverflow.com May 21 '13 at 10:01

This question came from our site for professional and enthusiast programmers.

1  
Try Raspberry Pi, Unix & Linux, Ask Ubuntu, or Super User instead. Stack Overflow is for programming questions. –  U2744 SNOWFLAKE May 21 '13 at 3:16

1 Answer 1

up vote 0 down vote accepted

These files are broken due to end-of-line conversion from the UNIX format (LF) to the DOS format (CRLF). One common cause of such corruption is FTP transfer in ASCII mode instead of binary.

However, if these drivers are the same as available at http://www.touchkit.com/Drivers.htm, they are ancient and useless for modern Linux versions; some drivers also contain x86-only binary parts without sources, and licensing is unclear. Don't waste time with them — instead, attach the touchscreen to a Linux computer, determine USB vendor and product IDs using lsusb, then search for drivers matching this device.

A likely match is the usbtouchscreen kernel module (if you are building the kernel yourself, you need to enable INPUT_TOUCHSCREEN and TOUCHSCREEN_USB_COMPOSITE options, and then select at least one subdriver, for TouchKit this should be TOUCHSCREEN_USB_EGALAX). For X11 you will need the xf86-input-evtouch package.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.