Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have what appears to be a rather unique problem:

I do all of my work on my MacBookPro because it's very powerful. However, since I commute to and from school by bicycle, I don't want to risk carrying my macbook in a backpack (what if I fall and the MBP dies?). As a result, I use a very low power machine (mid range Pentium4) at home as a thin TeamViewer client, though which I connect to my MBP.

Also, while at school, for ergonomic reasons, I use an external keyboard (wireless) and monitor. This external keyboard is a Windows keyboard, so I need some way to remap alt on my external keyboard to and vice-versa.

To this end, I tried using DoubleCommand. While this was a very useful application, it had the nasty side effect of remapping the keys on my MBP's native keyboard as well. Further, I lose the remapping when I connected from my TeamViewer client at home and am forced to use the windows key when I want .

So I switched to KeyRemap4MacBook. While this required a lot of configuration (and I mean a LOT), which I'm not opposed to, it turned out to be very flaky and decided to remap my mouse when I configured it not to (the same config would change its mind on whether to remap my mouse within 5 minutes). So this turned out to be a no-go.

A friend then told me that synergy is highly configurable, so I'm trying it out, but I don't seem to be able to remap keys on the synergy server (my MBP). Further, I don't know if remapping the keys on the external keyboard will remap the keys on the native keyboard. Also, I will have to do some really weird hackery to get it to work correctly when I connect from home using TeamViewer.

I tried setting up my MBP as the synergy server with the following config file, but that didn't seem to work:

section: screens
    cortana.local:
        alt = meta
        meta = alt
end

Does anyone have any thoughts on how I can solve this problem?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Teamview is already attempting to map the keyboard so it is expecting your mapping to be untouched. If you are using KeyRemap4MacBook you what to make the styles mapping selected explicitly exclude TEAMVIEWER so you don't get a double mapping situation.

If you need custom key mapping for this scenario using KeyRemap4MacBook PC to Mac styles you can find a great post here:

PC to Mac Switch – Don’t Relearn Your Keyboard Shortcuts

Also, setting up KeyRemap4MacBook to have multiple mapping profiles is very handy as well.

share|improve this answer

System Preferences should allow choosing different modifier key mappings for each keyboard:

I have used settings like this with KeyRemap4MacBook with no issues:

<?xml version="1.0"?>
<root>
  <devicevendordef>
    <vendorname>KINESIS</vendorname>
    <vendorid>0x05f3</vendorid>
  </devicevendordef>
  <deviceproductdef>
    <productname>ADVANTAGE</productname>
    <productid>0x0007</productid>
  </deviceproductdef>
  <item>
    <name>kinesis</name>
    <identifier>kinesis</identifier>
    <device_only>DeviceVendor::KINESIS, DeviceProduct::ADVANTAGE</device_only>
    <autogen>__KeyToKey__ KeyCode::COMMAND_L, KeyCode::OPTION_L</autogen>
    <autogen>__KeyToKey__ KeyCode::OPTION_L, KeyCode::COMMAND_L</autogen>
    <autogen>__KeyToKey__ KeyCode::COMMAND_R, KeyCode::OPTION_R</autogen>
    <autogen>__KeyToKey__ KeyCode::OPTION_R, KeyCode::COMMAND_R</autogen>
  </item>
</root>

You could also try using ControllerMate.

share|improve this answer
    
Did NOT know that the built-in mapper had settings for different keyboards. Thank you!! –  inspectorG4dget May 22 '13 at 18:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.