Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following network setup:

All of my ethernet devices (NAS, AppleTV, TV, PS3, etc) are connected to the Gigabit switch. Also connected is the Devolo 200AVmini. The other end of the Devolo 200AVmini is the 200AV Wireless N adaptor, which is in my office as the Brightbox will not reliable reach that far.

The problem is that when I connect over WiFi to the router, I cannot ping or access any devices on the switch.

If I connect to the Devolo network, I CAN access the devices on the switch.

Devices on the switch have full internet access, get DHCP from the router and are all on the same subnet (255.255.255.0 / 192.168.1.x). I can access the router admin (192.168.1.1) when on either wireless network.

The Devolo kit has DHCP services disabled.

I have a WiFi IP Camera connected to the router WiFi. I can only access this if I am connected to the router's WiFi. If I connect to the Devolo wifi (which takes me to the switch network), I cannot access the camera anymore.

Any thoughts on this? It doesn't seem to make sense to me. Is there some kind of ARP problem? Any suggestions on debugging or resolving this?

This might help to clarify. Devices in parallel are connected to the parent device in the list. Eg, Apple TV and NAS are connected to the Switch. The Switch is connected to the Router.

  • Modem
    • Router
      • IP Camera
      • WiFi devices (eg iPhone 5 (when downstairs))
      • Switch
        • Apple TV
        • NAS
        • PS3
        • Devolo AV200mini
          • Devolo AV200 Wireless N
            • Work PC
            • iPhone 5 (when in office)
            • Printer

My "Work PC" can ping and communicate with any device on the Switch, but only when connected to the Devolo WiFi (my Work PC doesn't have ethernet). When on the Router WiFi, all devices on the switch network are not visible (no ping or anything).

BUT on the Router DHCP listing page, they are listed as connected.

Interestingly, when on the Devolo wireless network, I cannot access any devices connected over WiFi on the Router, but I CANT access the router's admin page....

Any advice appreciated.

Nick

share|improve this question

migrated from serverfault.com May 22 '13 at 11:16

This question came from our site for professional system and network administrators.

2  
Some wireless access points isolate clients from the rest of the local network by default. You might want to check settings on the AP. –  Flup May 22 '13 at 10:49
    
Interesting - so this would be on the EE Router? –  Nick May 22 '13 at 10:52
    
More likely on the Devolo (that's your AP if I'm reading correctly), but worth reviewing settings everywhere. –  Flup May 22 '13 at 10:53
    
There are two WiFi AP's... The Brightbox and the Devolo (two WiFi networks). Devolo is connectd to the switch and allows me access to the switch. The switch is connected to the Brightbox, but when on the Brightbox network I cannot get to the switch. But the Brightbox lists the devices on the switch as connected. –  Nick May 22 '13 at 11:02
    
I wonder why this was downvoted... –  Nick May 22 '13 at 11:08

1 Answer 1

up vote 1 down vote accepted

Your router's wireless is isolated from the ethernet ports; which is considered to be a good security practice. There should be a setting in that 192.168.1.1 box's admin area for this "feature". Additionally, there can be options for isolating all clients from each other. I have had this exact situation on AT&T Uverse Router/AP.

And draw a network diagram. You'd be amazed what you might find out that you weren't aware of.

share|improve this answer
    
Thanks ChrisK! I had no idea that were isolated... I'll have to do some network rejigging. :) –  Nick Jan 7 at 11:29
    
Now I know what that feature is called, I have found many more people with the same problem. Aparantly, it's forced to be enabled on that router - neowin.net/forum/topic/1133554-benefits-of-the-various-uk-isps/… :-( –  Nick Jan 7 at 11:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.