Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to run a programs setup.exe file, but no install windows/prompts start up.

I've tried running the setup file as a local-admin, as the domain admin, I've deleted and re-downloaded the setup files, and I've done Alt+Tab to see if the window was hidden beyond the border of the monitors.

This program has been installed on many other end-user PC's, but this one seems not to want to work. I've even copied the setup folder from a different PC instead of from the server, ruling out the source folder being borked.

After double-clicking on the setup file, the Windows 7 loading wheel pops up, but no prompts/windows pop up. A setup.exe entry does show up in Task Manager, though. Nothing shows up in the Event Logs.

Where else should I look? What should be my next steps in troubleshooting?

Windows 7 x64 Ultimate (same as the other working computers). UAC is disabled. Setup.exe uses InstallShield.

share|improve this question
Have you tried turning it off and on again? (In all seriousness) – Tanner Faulkner May 22 '13 at 21:36
@Tanner Haha...yes... – Kruug May 22 '13 at 21:40
Are there any suspicious entries visible in the Windows Event Viewer? – Axel Kemper May 22 '13 at 21:43
Are you sure the setup.exe in Task Manager is the setup.exe you ran ? It could be somebody else tried to install something before on this machine which got a borked install. The setup.exe of that is automatically re-launched after each reboot trying to complete the install (which never happens). At that point your setup immediately closes because another setup already runs. Kill the setup.exe in task-manager and then retry your setup (without rebooting). – Tonny May 22 '13 at 21:44
@Kruug Then whoever made the installer explicitly set it up as a silent install, with these options disabled. My best guess is that something goes wrong with the install on this particular PC and the installer just keeps waiting for input, which you can never give because all interaction is disabled. I'm signing of now. Past midnight here and the alarm-clock will go at 6:00 AM. Will check back here tomorrow, if I can think of something else. – Tonny May 22 '13 at 22:05
up vote 3 down vote accepted

Interesting question :)

Are you sure that computer can run other installers, and that the problem is not windows installer itself?

Also, sometimes you can extract the setup files from certain installers. Then you will get a new setup file that doesn't have the preferences (silent, no interaction) set to it, as the parent installer has. Check if you can extract files from the installer with an unzip tool like WinRar or Universal Extractor.

It might be worth a shot to check if all system files are correct. Hit windows key + R, type 'cmd'. Then in the newly opened dos venster type 'sfc /scannow'.

Finally you might try running the setup.exe in safe mode. See if that changes anything.

share|improve this answer
This one did it. I went into MSConfig, disabled all non-Microsoft start-up objects, and it installed. – Kruug May 23 '13 at 14:55
@Kruug, I'm glad it helped you ;) – Forza May 23 '13 at 15:38

Run Process Monitor. Filter for setup.exe. Compare what happens when it terminates with an example that works correctly.

share|improve this answer

Kill the setup.exe process in the task manager and then try rerunning it. Sometimes you get a "zombie"* process that's launched but for whatever reason bugs out and doesn't load correctly, preventing a new one from starting, and doesn't go away by itself.

*Note: I'm using "zombie" in a colloquial sense. "Zombie" processes are real things in OS terms, but I am not certain of what state these processes are in.

share|improve this answer
We seem to have the same idea:-) I only saw your answer after I completed my comment. – Tonny May 22 '13 at 21:45
I've done this to no avail. :) Thanks for the suggestion, though. – Kruug May 22 '13 at 21:48
Yes, this happens to me too sometimes, and I'm on Vista. – sammyg May 22 '13 at 21:50

Try temporarily disabling the antivirus. Especially if the antivirus you use on this PC is different from the other PCs. I have seen similar behaviour many times before, and this has fixed the problem a few times.

Note: only do this if you're certain the setup file is not infected with any malware.

share|improve this answer
Same A/V as the other PCs, but it's worth a shot! – Kruug May 22 '13 at 21:50
Tried running with the A/V turned off, still no luck. – Kruug May 22 '13 at 22:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.