Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of my USB Sticks just kind of broke and now it's name and all file names consist of pretty much random characters, like ‗t|%ò┼½.¯f¥.

I did some research and its probably my file table that is gone, but I'm not too sure about that since the device name is also affected. I tried to repair the device with windows 8 repair tools (chkdsk etc.), however they say there is no problem. My files are safe i guess since i managed to get them off the USB stick with PhotoRec, however I'd rather repair that device as well.

So: Is that USB stick hardware is broken or still safe to use? If safe to use, how can i fix it? It would be nice if the files would not go down the drain, but if there's no way around it deleting everything on it is fine as well. I tried saving it with TestDisk, but I didn't manage to make it work.

The drive looks like this

enter image description here

share|improve this question
    
just to clarify, did you run chkdsk with \p to indicate that you'd like it checked even if it is currently marked as clean? –  Frank Thomas May 23 '13 at 12:11
    
Did you try just formatting the drive with a new label? Do a full format for good measure. –  Nathan C May 23 '13 at 12:15
    
I ran chkdsk with /f /r. How do i run chkdsk with /p? Says I need the recovery console, but i dont have a Windows CD here. –  connan May 23 '13 at 12:59
    
thats odd. I would not expect the /p option to require the recovery console. try /p and /f, since /f will ask to schedule on reboot if the volume is mounted. thats the only reason I can think of that recovery console would be required to run chkdsk. –  Frank Thomas May 23 '13 at 14:34
    
Try formatting it under Linux (using GParted) or even on an Android device if possible. Sometimes that helps. If it doesn't then most likely your USB stick is broken beyond repair. –  Karan May 23 '13 at 15:23

2 Answers 2

Late answer here, but is it encrypted? Happened to mine when I installed truecrypt and it encrypted it automatically. Had to format and reload all the data as none of it was readable and I did not know hte key that truecrypt used.

share|improve this answer

looks simply to be an outdated driver... try windows update or reformat the drive with the computer
or if while transferring data you unplugged the drive it could have off set memory addressing on old drives this is more likely just one bit and the entire name file is shot.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Olli Feb 13 at 9:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.