Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed VB 4.2.12 on Windows 7. I also installed Oracle_VM_VirtualBox_Extension_Pack-4.2.12. I then created a Win 8 Guest on it & I am able to boot up and work on the Windows 8 Guest OS.

However, I am unable to share files between host and guest

  1. I have enabled Bidirectional Clipboard and Bidirectional Drag'n'Drop. However I am neither able to copy/paste text or files or dragndrop files.

  2. When I click on Shared Folders - it says I should install Guest Additions. When I click on the Install Guest Additions menu nothing happens.

  3. I finally decided to share a folder on my host machine & did a

    net use z: \\HostIPAddress\sharename 
    

    from the guest machine.
    This succeeded, but when try to change to z: , it says access denies. I have given full control to the share to everyone on my host machine.

What am I doing wrong here? Any solutions, fixes, work arounds?

share|improve this question
1  
You have to install the download.virtualbox.org/virtualbox/4.2.12/… on the guest operating system for these features to work. Just run the installer by hand if you need to after you mount the .iso file. –  Ramhound May 23 '13 at 13:31
    
As @Ramhound said, you need to install the Guest Additions. Just selecting "Install Guest Additions..." from the "Device" menu is not enough. That menu item mounts an ISO in the guest machine's CD-ROM drive, so you need to run the installer from your CD-ROM drive on the guest machine. –  heavyd May 23 '13 at 14:30
    
@Ramhound - please write it as an answer - I'll accept it. Now I have installed Additions. The copy/paste of text works now (bidirectionally). I am also able to access Shared folders - so the file transfer issue is resolved. However 1. DragnDrop doesn't work - may be I am doing something wrong. 2. I am not able to copy a file/dir (right click explorer Ctrl-C) & Paste the file/dir into the virtual machine - this works on VMWare Workstation. I can post these as a sep question - once I accept your answer here. –  user93353 May 23 '13 at 15:35
1  
@user93353 - Drag and Drop into a VMWare virtual machine hasn't worked for me either since using Windows 8 as the guest OS. While your using VirtualBox I highly suspect its an issue with Windows 8 itself. I would report the issue to the VirtualBox community and see if they can help. –  Ramhound May 23 '13 at 15:43
    
@Ramhound - ok, thank you - as long as shared folders work, that's good enough. Please write your comments as an answer so I can accept it. –  user93353 May 23 '13 at 15:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.