Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Even when I have an empty buffer in vim, supertab tries to do a completion at the begining. How can I configure supertab to only try tab-completion if there's a character?

share|improve this question
up vote 1 down vote accepted

Supertab triggers insert-mode completion only when there is non-whitespace text before the cursor. Behind whitespace, or at the beginning of a line, a <Tab> character should be inserted. Something's wrong with your setup.

Note that you can always insert a literal <Tab> with <C-v><Tab> (on Windows, you may have to use <C-q>).

share|improve this answer
    
Any ideas what could cause this problem? – AME May 23 '13 at 14:45
    
A new git checkout solved the problem. – AME May 23 '13 at 16:07
    
Ah, great you've solved it! So it was likely script corruption?! I couldn't think of any reason, sorry. – Ingo Karkat May 23 '13 at 16:08
    
I have no clue. I can't remember changing anything in the git module. however pulling did nothing but removing the module and checking out a fresh copy helped. :) – AME May 25 '13 at 14:34

I had the same problem. I have used the old version of snipmate (the version maintained by msanders). When I updated to this version maintained by garbas and others the problem has gone.

(I have tried to remove supertab and clone again. This alone had not fixed the problem.)

share|improve this answer
    
This answer led me to the snipmate fork FAQ. I didn't need to re-clone supertab, but an old snipmate was my problem too. – sappjw Jan 19 '15 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .