Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi guys I am using Ubuntu 9.04. Things are cool, except for the annoying part about networking.
Say, if I am connected to a LAN cable, and somehow the connection is lost (let it be network congestion or my kicking the power cable), I will then be unable to get connected again.
I tried restarting the modem, unplugging and replugging it, clicking the network icon and telling it to connect, but the only thing that works is to restart the computer.
I know Karmic will be out in a few days but there's no warranty that the problem will be gone. So please tell me why and how to fix this, or at least some workaround (so that I don't have to restart the whole PC).
PS: everything is fine under Windows, which means it's not a hardware fault.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Run "tail -f /var/log/messages" before replugging your network cable. What messages appear? What if you run "sudo ifconfig eth0 down ;sudo ifconfig eth0 up"? Again, what messages appear in /var/log/messages? What if you run "sudo dhclient eth0"?

share|improve this answer
    
great, thanks "sudo ifconfig eth0 down ;sudo ifconfig eth0 up" fixed the problem –  phunehehe Oct 29 '09 at 13:35
add comment

Try

service network restart

in the terminal.

share|improve this answer
    
you mean service networking restart? it says "OK", but doesn't connect :( –  phunehehe Oct 29 '09 at 8:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.