Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've unintentionally damaged my external 2TB HDD which is also my warehouse of all the data I have. It was done using this guide: http://www.plop.at/en/winusbinstall.html#s2 . There in the situation 2 I did something like:

fdisk /dev/sdc
p
7
a
1
p
w

Currently, the fdisk output of the device looks as follows:

Disk /dev/sdc: 2000.4 GB, 2000365289472 bytes 255 heads, 63 sectors/track, 243197 cylinders, total 3906963456 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x0005f107

Device Boot Start End Blocks Id System /dev/sdc1 2048 3906963455 1953480704 7 HPFS/NTFS/exFAT

It's a WD MyPassport 2TB. Can someone please help to recover the data?

EDIT: So what happened is that apparently I changed the FS type flag or something. So now I can't access data since since OS (both Ubuntu 13.04 and Win7) doesn't recognize the file system of the device. That is the actual assumed problem behind it.

share|improve this question

3 Answers 3

As you have said, the guide is providing exactly that: Changing the File System type into some other format which unfortunately both Windows and Ubuntu can't recognize.

From your screenshot it looks like your Ubuntu can still see the device (/dev/sdc) although Ubuntu can't mount it.

How about changing the File System type into what it was before? (Which I hope you still remember what it was before).

So after you do:

  • sudo fdisk /dev/sdc
  • p - to check the entries
  • t - to change type
  • L - to check all the hex codes of known File Systems
  • And now its up to you to find out what it was and enter the correct hex code
  • w - write changes
  • (Hopefully it works and mountable by then)

You can try from the most common one. FAT32 can and often used to handle 2TB HDD (to ensure compatibility among different OS). NTFS is another good option, and still accessible by Ubuntu. Sorry I don't have the hex codes as I don't have a VM to test at the time of writing this.

Good luck.

share|improve this answer

1st Solution: (Tested and Failed)

On a recent Tekzilla episode they recommended a free data recovery application called Recuva. I've never used this application before but it sounds promising. I would however recommend you clone the external hard drive to another hard drive before attempting to recovery your data just to be safe.

piriform.com/recuva

2nd Solution:

Attempt to clone the external hard drive to a larger drive using Clonezilla or other preferred disk cloning software before doing this.

  1. Perform a quick format using the NTFS file system on the external drive
  2. Attempt to recover the data again using Recuva

Because your doing a quick format the data on the drive will not be written over.

share|improve this answer
1  
Either I don't completely understand your answer or you don't understand my problem. So the deal is that I can not access data since since OS (both Ubuntu 13.04 and Win7) doesn't recognize the file system of the device. That's why I can't access the data and that's why I can't copy anything, otherwise the data should not be corrupted or anyhow damaged. –  Denys S. May 24 '13 at 14:11
    
    
Not sure if the above article is the same as your problem but it appears that another person was able to recover files when using Recuva even when the file system was corrupt. –  MHrappstead May 24 '13 at 14:25
    
Most likely that person had different issue, since even this free tool says "Unable to read boot sector". –  Denys S. May 24 '13 at 14:42
    
Every time the devices is accessed widows suggests to format it. –  Denys S. May 24 '13 at 14:42
up vote 0 down vote accepted

So after trying ***loads of tools I couldn't save it. The best thing to do here IMHO is to use paragon recovery kit as the first thing you ever do. And then try other stuff. Reason: other tools may corrupt it even more which apparently was my case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.