Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok. After several hours of searching Google, I can not find exactly what I need. After mounting an Ubuntu NFS share in Windows 7 via command line, it says it mounts successively. I know it was successful because I can (in cmd) cd to the drive letter I chose (in this case W), and then dir just fine. Lists all the files as it should.
The issue comes in with explorer. For some reason it will not show the new drive letter (again, W), and it does not show up in disk management.

Any suggestions on what needs to change?

share|improve this question
OS? :-)..................... – mdpc May 24 '13 at 20:14
7 Ultimate. I guess I thought that would have been implied since to my knowledge, Ultimate and Ultimate N are the only 2 that can use the NFS service. – Oberst May 24 '13 at 20:19
What happens if you try to mount that nfs share directly from Windows Explorer's 'map network drive'? – Mxx May 24 '13 at 20:22
... ... Well. After screwing with this for 4 hours, it finally decided to work correctly. The error it WAS giving was something along the lines of, it just cant find the network location. I appreciate the help guys. I guess it was just a windows moment? Haha. – Oberst May 24 '13 at 20:29
Actually, not quite. I just tried to mount as a network drive as V, and it worked fine, after it was mounted as W in cmd. Could that potentially be the problem? Should I mount it as Z in cmd next time and mount as a network drive the letter I want? O_o – Oberst May 24 '13 at 20:31

I stumbled upon this question just now, because I experienced the exact same problem - and managed to solve it! Although probably uninteresting for OP after several month, others may benefit.

If you mount NFS shares from an elevated command prompt (Run as administrator), the mount will not show up in the explorer running on normal user rights. The solution is to unmount the share and remount it, either from explorer or from an ordinary command prompt. Admin rights are not required for NFS mounts.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.