Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 8 operating system (Host) and virtual box installed in it. I have installed Ubuntu 13.04 os installed as a guest in the virtual box. During the setup i added two network adapter, primary one is the network type adapter and the secondary is the host only adapter. Im able to access apache web server of the guest os (ubuntu) from windows 8, whereas im not able to access IIS of windows 8 from ubuntu os. In the process, i added Network service, everyone in the security list of the default website and gave them full control access. Im able to ping the ip of windows 8 from guest os whereas not able to access iis. Can anyone please help what im missing here.

share|improve this question

migrated from stackoverflow.com May 25 '13 at 15:10

This question came from our site for professional and enthusiast programmers.

    
You could try this link for your reverse problem :) –  Oli May 25 '13 at 14:01
    
Off topic, since, as per faq, Stack Overflow is for programming questions only (which this does not appear to be). Super User might be the right place. –  Dukeling May 25 '13 at 14:02
1  
Is this an accurate rephrase: You can communicate over port 80 from win8 to virtual client, but not in the reverse direction? Did you turn off your Win8 firewall for incoming port 80 requests? Can you access the Win8 port 80 from other machines on your network? –  jdh May 25 '13 at 15:26
    
@Oli: I could easily access apache webserver of Ubuntu guest os with no problem, but the problem is in the reverse direction –  user1744973 May 25 '13 at 18:07
    
@jdh: What you have said is actually true. I did turned off my firewall, but it still didn't helped me. For your second question, Im able to connect my other laptop to the current one with the firewall being off. –  user1744973 May 25 '13 at 18:11

1 Answer 1

up vote 3 down vote accepted

If you have a router / other device that is acting as DHCP server:

  • Set Ubuntu VM as Bridged Adapter, and it will get its own unique IP address. Windows Host should now be able to access the unique IP of the Ubuntu (and get its apache web page) and Ubuntu VM should also be able to access the unique IP of the Windows Host, and get the IIS website.

If you don't have a router / other device that is acting as DHCP server:

  • As what you have set, use "Host Only Adapter" which is as close as directly linking 2 computer together via an ethernet cable, and simply picking a random IP on the same subnet, which technically should allow you to talk / ping / access each other web server.

Few other things you can check:

  • Try turning off windows firewall temporarily to see if this is the cause
  • (This one is a bit of a long shot guess) enable Promiscuous mode to allow all? (on both network and host only adapter)

Hope this helps.

share|improve this answer
2  
Issue has been resolved. I somehow missed something while turning off the firewall :P, Turning off the firewall was allowing the connection to and from the guest os. I have added a new rule in the firewall to allow connections from the guest os IP. –  user1744973 May 25 '13 at 19:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.