Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can access, read and download from host via FTP, but can't upload file.

I tied to use Transmit (on Mac) and Filezilla also, but no success.

Then tried same on different host and got same problem.

Here is the screen of error:

enter image description here

I tried also PASSIVE mode on FTP client, and viceversa, but again not solved.

share|improve this question
    
I know this is probably the first thing you checked.. but your username/password for the FTP Server have Write Access? Oh, and have enough space left for you to upload more files? –  Darius May 25 '13 at 15:37
    
Yes I checked this all, but everything is ok. It's working in windows CuteFTP or Filezilla or other FTP clients. I got problem only on Mac based FTP clients. –  zur4ik May 26 '13 at 6:49
add comment

2 Answers

It sounds like the account you’re using doesn’t have Write access to the server, you need to confirm that with the server admin.

share|improve this answer
    
Account has write access because, when I use it with Windows based FTP clients, it's working properly. I get error on Mac based FTP clients. –  zur4ik May 26 '13 at 6:51
add comment
up vote 0 down vote accepted

After long time searching of solution finally found a solution.

Problem is caused by macs MTU settings:

Settings>Network>Advanced>Hardware

Put: MTU:1400

Finally FTP transfer is working properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.