Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using ffmpeg, trying to convert 1080p to 1080i. I know that -vf tinterlace should do that, but I don't know the exact syntax of use. Currently I'm trying this:

ffmpeg -i <input file.mp4> -c:v libx264 -c:a aac -vf tinterlace <output.mp4>

When I check the generated output in a video analyzer tool like Mediainfo, I see that it's still progressive. I know there must be some mistake in the command. I need both top fields first and bottom field first formats of interlacing to be applied to 1080p source video content.

share|improve this question
    
Are you sure the mode you want is the right one? tincerlace has other modes that you might need. I'm thinking you need to supply another flag that tells x264 to do interlaced encoding, but I'm not sure at the moment. (Not a real fan of interlaced video—I avoid it wherever I can.) –  slhck May 26 '13 at 8:59
add comment

1 Answer

Try -flags +ilme+ildct instead of -vf tinterlace

share|improve this answer
    
Would you be able to give the entire command path? –  Raystafarian Jul 18 '13 at 21:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.