Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a static IP PPPoE connection from my ISP provider, and I am running a VNC server on it, and needs to connect a PPPoE connection on boot.

Is there a solution to that?

share|improve this question
add comment

2 Answers

Follow these steps:

  1. Go to Start menu and type in the search field ncpa.cpl and hit enter
  2. Right click your PPPoE Internet Connection and select Properties
  3. Go to Options tab and uncheck Prompt for name and password, certificate, etc., and set Redial attempts to as many as you want, and also set Time between redial attempts to, say, 3 seconds and then click OK

Make sure your PPPoE connection is set to Default by going to Control Panel->Network and Sharing Center->Change Adapter Settings and right-clicking on this internet connection and selecting Set as Default Connection

Now, type in the start menu search field inetcpl.cpl and hit enter and go to Connections tab.

  • Select your PPPoE connection
  • Select Dial whenever a network connection is not present.
  • Click Set default if button is active and click OK.

Now, just log off and and log in. The connection should be dialed automatically.

EDIT: Right-click on All Programs in Start menu and click Open. Now, open Programs folder and double-click on Startup folder. Type in ncpa.cpl in Start menu search field and hit enter. Just drag-and-drop your pppoes internet connection into this Startup folder. Do log-off, log-in.

share|improve this answer
    
I will try as soon as Windows Update finished. Thanks a lot for your answer! –  Shane Hsu May 26 '13 at 9:39
    
It seems to do nothing on boot, I doesn't even connect on login. Is there a script or startup item I can do? –  Shane Hsu May 26 '13 at 10:53
    
Added another possible solution. Just try this. –  om sai May 27 '13 at 6:08
    
Yes, that doesn't work either. I've tried that. It connects only when logged in, not on boot. BTW, I am not using 7 strictly, 2008 R2. –  Shane Hsu May 27 '13 at 13:04
    
You are saying <needs to connect a PPPoE connection on boot –  om sai May 27 '13 at 14:43
show 3 more comments

Use this: Automatically dial the default Internet connection at Windows startup

With the slight modification that do not set "When I logon", but set "At system startup".

  • You still need to disable "prompt for name and password" as "om sai" said.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.