Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have LAN with three ubuntu 12.04 machines. Everyone see only itself and router:

nmap -v -sP | grep -v "host down"
Nmap scan report for D-link.HomeGateway (
Host is up (0.0037s latency).
Nmap scan report for i159 (
Host is up (0.00033s latency).

So on... I can't get access to other machines via ssh, IPs of the LAN can't ping each other. What is the cause? How to solve?

EDIT: What I have tried so far:

  • nmap checking for IPs visibility.
  • Ping IPs from each other, try ssh connection.
  • sshd_config checking.

I have asked this question on serverfault, but the question was downvoted as offtopic. So, I'll try my fate here.

share|improve this question
Is the problem only with Ubuntu? Do you have the same problem with other operating systems? How is your network setup? Which router do you use? – user 99572 is fine May 26 '13 at 9:28
I have no machines with other OS. What exactly you need to know about network setup? I use D-Link dsl-2640u. – I159 May 26 '13 at 9:40
"What exactly you need to know about network setup?" Just checking for any unusual network configuration. Have you tried: <…;? – user 99572 is fine May 26 '13 at 10:48… (Sorry, there was a formatting issue. My bad.) – user 99572 is fine May 26 '13 at 11:10
22 port opened on all the machines. I can't ping each other IPs of the LAN, so I believe it is not ssh problem. The 22 port is set in ssh_config. – I159 May 26 '13 at 11:15

If you want to use ssh on ubuntu you first need to configure it.
Have a look at this documentation for more info

Now since you say pcs cant ping each other that can be very interesting. Try and see in the router settings if you can spot enything like "block broadcast" or any weird firewall config.

share|improve this answer

This is an old question, but it was google's second suggestion when I searched for a solution to the same problem. There a few things to try:

  • As mentioned in this answer to a similar question "Can't ping other machines in my network" there may be a bug in how the machines (unlikely in this case) or the router is handling WPA2-PSK.
  • As explained here you should also check that if your router has the option "Wireless Isolation Within SSID" it is set to "No".
  • Finally (this is what worked for me) try turning on "Routing Information Protocol" (RIP). In my Netgear routers this was turned off by default.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.