Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have copied a logical volume from Server A to Server B, using dd command, however every time I try to mount the volume

root@munin:~# mount /dev/DS/data_snap /mnt/
mount: you must specify the filesystem type

I tried using different options such as -t ext4 I get the following

root@munin:~# mount -t ext4 /dev/DS/data_snap /mnt/
mount: wrong fs type, bad option, bad superblock on /dev/mapper/DS-data_snap,
   missing codepage or helper program, or other error
   In some cases useful info is found in syslog - try
   dmesg | tail  or so

when I run dmesg | tail , I get the following

[ 3050.756552] EXT2-fs (dm-0): error: can't find an ext2 filesystem on dev dm-0.
[ 3141.079177] EXT4-fs (dm-0): VFS: Can't find ext4 filesystem

This is the result of fs check

root@munin:~# fsck.ext4 /dev/mapper/DS-data_snap
e2fsck 1.42 (29-Nov-2011)
fsck.ext4: Superblock invalid, trying backup blocks...
Error reading block 557056 (Invalid argument).  Ignore error<y>? cancelled!

/dev/mapper/DS-data_snap: Invalid argument while reading block 557056

/dev/mapper/DS-data_snap: Invalid argument reading journal superblock

fsck.ext4: Invalid argument while checking ext3 journal for /dev/mapper/DS-data_snap

/dev/mapper/DS-data_snap: ***** FILE SYSTEM WAS MODIFIED *****

/dev/mapper/DS-data_snap: ********** WARNING: Filesystem still has errors **********

Any ideas on how to fix this?

share|improve this question
add comment

2 Answers

Was the source partition unounted or mounted read-only when you made the copy ?
You just can't copy an partition that is mounted write-able and expect it to work. You will have copied garbage.

share|improve this answer
    
I took a snapshot of the volume, then I did a dd copy of that snapshot to another system. –  user1007727 May 26 '13 at 22:13
add comment

I don't think I'd trust dd to copy a snapshot volume; it's much better to use a filesystem aware tool. I back my systems up by making LVM snapshots and copying the filesystems off with fsarchiver. I've had to restore twice and it worked well both times.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.