Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm following this tutorial because I'm having problems with the Task Scheduler service:
http://technicallyeasy.net/2010/10/how-to-fix-keyset-does-not-exist-for-scheduled-tasks-in-windows/

Basically (in case the link dies), it says that you should go to C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18 and delete everything that's in there.

Here's the problem I'm having - there is a single file, marked as hidden, system and read-only. The file name is "d42cc0c3858a58db2db37658219e6400_46884bcb-8fba-461e-a2ee-e996218ba78a".
When I try to delete it, I get the following message:
Cannot delete X : Make sure you specifiy the correct path

The file is definitely there, as I can browse to it via Windows Explorer. I assumed that the problem is the "system" attribute. I ran
attrib -s "path\to\the\file"

and the output:
Unable to change attribute - "path\to\the\file"

When I try to remove the hidden or read-only attributes instead, I get:
Not resetting system file - "path\to\the\file"

Once again, this is a file, not a folder.
Any ideas greatly appreciated!

PS: OS is Windows Server 2003 r2 x64

share|improve this question
    
Did you try "attrib -s -h <file>" or "attrib -s -h -r <file>"? What is the output of "cacls <file>" (do you have enough rights on the file)? –  Werner Henze May 27 '13 at 11:21
    
"attrib -s -h <file>" or "attrib -s -h -r <file>" both produce the second error "Not resetting system file". I am certain that the account we're using has enough privileges to perform the operation. I have no idea what else may be wrong.. –  Kaloyan Doichinov May 27 '13 at 13:07
1  
"I am certain that the account we're using has enough privileges to perform the operation." I am not. Therefore I asked for cacls output. –  Werner Henze May 27 '13 at 13:27

1 Answer 1

Attrib is giving me some problems today too. What I would try is "rd S-1-5-18 /s" from a command prompt in C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA. Put the folder back if this works. There is the "take ownership" option - http://cdn5.howtogeek.com/wp-content/uploads/TakeOwnership.zip from the right click menu. Otherwise that file is in use and needs to be released by whatever .exe is using it. The path and file name don't exceed 256 so something is using it or windows is just mad at you.

share|improve this answer
1  
Can you give more details about the file you linked to? While VirusTotal says it's not malware, bare links of this kind can be seen as suspicious. –  DragonLord May 1 at 21:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.