Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a number of computers connected to a WiFi router - either over WiFi or Ethernet. Some Windows and some MAC. The WiFi router is connected to a cable modem.

The WiFi router is doing the DHCP for the LAN devices.

If I ping any of the LAN devices using their hostname ping returns the external/WAN IP address instead of the LAN ip. So if I do "ping kitchen" the response is something like 67.217.66.131 instead of 192.168.0.50.

I suspect this is causing some of the other issues I have related to devices and file shares not being found between the various machines as in effect it looks to me like all the devices have the same IP as they see the NAT side address and not the LAN.

I'm guessing there is a solution to this but I'm unsure where the problem lies.

share|improve this question
    
Does the ping issue happen between any two computers, or just specific ping sources/targets? –  gronostaj May 27 '13 at 11:14
    
What DNS Servers are your computers using? 67.217.66.131 is in the range of opendns.com, have you configured anything for opendns.com? –  Werner Henze May 27 '13 at 12:02
add comment

2 Answers

This is DNS server issue.

Your DNS server has an entry on their end called 'kitchen' and that is why your "ping kitchen" ended up resolved as that.

When I attempted to do "nslookup kitchen" on my PC, I actually got:
Non-authoritative answer:
Name: kitchen
Address: 67.215.65.132

So my DNS server (openDNS - 208.67.220.220) actually have an entry for kitchen as strange as it may sound.

Try again with other Laptop/PC names you have, chances are you will get a local resolve (local IP) if and only if the same name are not existing in the DNS server.

Edit: Since you mentioned you DO use openDNS server.. maybe its time to use other one?

You might try DNS Benchmark tool (Windows only) made by GRC available here and see if you can find better one, and hopefully will not return a bogus entry. Unfortunately for me, my best DNS benchmark are OpenDNS so I'm sticking with it. You may have better luck elsewhere based on that DNS Benchmark.

share|improve this answer
    
I am using OpenDNS however the names/IP's I gave were illustrative. The Kitchen laptop is actually called "kitchen-w8". The effect I see happens between all the devices as far as I can tell. In other words no matter which one I am on they see all the local hostnames as being my external IP address. So I agree it's likely a DNS issue or something to do with the gateway. But how do I solve it? –  MozzerSU May 27 '13 at 14:19
    
I've just tried ping blahblah (no device called that) and it "resolves" and I get a response!! So that's weird... –  MozzerSU May 27 '13 at 14:20
    
o.O I wonder if its just OpenDNS somehow have those entry in their server... somehow. By the way I also tried doing nslookup kitchen-w8 8.8.8.8 (Google's DNS) and they return they can't find anything. So I believe this is just OpenDNS DNS server acting up, or somehow have those somewhat bogus-looking entries. –  Darius May 27 '13 at 17:33
2  
Apparently this is an OpenDNS “feature” which is known to cause problems in some cases; OpenDNS returns the IP of their server in response to request for any nonexistent domain, so that the user which enters a nonexistent site name in a browser will get their search page instead (and, of course, this page will contain ads). –  Sergey Vlasov May 27 '13 at 18:14
    
Sergey: i.e. how they make money in the first place, I'd like to point out. They provide an excellent service and they charge nothing for it, not exactly strange that they have ads. –  bigbadonk420 May 27 '13 at 18:49
show 1 more comment

FWIW, the setting causing the issue for me is that the computer that was trying to resolve the IPs had a manually configured DNS server address chosen. It was bypassing the router when trying to resolve the IP address and so the public DNS server (OpenDNS, in this case) was responding with my external IP address. To change the setting I went to

Network Connections -> Connection Properties -> TCP/IP Properties -> and select "Obtain DNS server address automatically"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.