Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm doing maintenance on a HP DC7100 Small Form Factor.

After reinstalling Windows XP on the machine, installed all the drivers I then decided to upgrade the BIOS firmware.

It all went well, but, by mistake, I shutdown the computer after it restarted and displayed the initial boot information.

Now, when I try to boot up the computer, it keeps beeping.

It beeps 9 times (including front red led).

After searching on Google for the beep codes table, I found out it is due to bad ROM (BIOS).

I then read on how to fix it without replacing any component. I found out Rompaq Diskette. Hmm, how to boot it then?

Searched again and some people say to use a PS/2 keyboard, which I use to be able to boot the diskette. Pressed Windows+B in various timing combinations, but it keeps on going for the beeps and does not load the diskette information.

Any help would be appreciated, since the computer isn't mine and I don't want to end up on a dead computer.

EDIT: I already tried clearing the CMOS, and it didn't work either.

share|improve this question
    
So you shut it off before the BIOS upgrade was complete? –  Ƭᴇcʜιᴇ007 May 27 '13 at 16:19
    
Sure hope you didn't end up bricking someone else's PC. What's Win+B for, to boot from the floppy? –  Karan May 27 '13 at 16:20
    
@techie007 I guess, because it ended up doing that after I shut it down before it finished loading Windows XP. –  silentw May 27 '13 at 16:21
    
@Karan that's correct! –  silentw May 27 '13 at 16:22
1  
According to this document, 9 beeps means “Wrong power supply input voltage”, and invalid ROM checksum should result in 8 beeps — are you sure you hear 9 beeps? However, the Technical Reference Guide says that 9 beeps means ”System powers on but fails to boot” on page 7-5 (137 in pdf). –  Sergey Vlasov May 27 '13 at 17:09

1 Answer 1

From the HP website:

Also here is the manual for disassembly.

Clearing CMOS* The computer's configuration (CMOS) may occasionally be corrupted. If it is, it is necessary to clear the CMOS memory using switch SW50. To clear and reset the configuration, perform the following procedure:

  1. Prepare the computer for disassembly. CAUTION: The power cord must be disconnected from the power source before pushing the Clear CMOS Button (NOTE: All LEDs on the board should be OFF). Failure to do so may damage the system board
  2. Remove the access panel.
  3. Press the CMOS button located on the system board and keep it depressed for 5 seconds.
  4. Replace the access panel.
  5. Turn the computer on and run F10 Computer Setup (Setup-utility) to reconfigure the system. When the CMOS button is pushed or the jumper is removed, both the power-on password and the setup password become invalid because both are stored in the configuration memory. You will need to reset the passwords. Disabling or Clearing the Power-On and Setup Passwords
  6. Turn off the computer and any external devices, and disconnect the power cord from the power outlet.
  7. Remove the access panel.
  8. Locate the header and jumper labeled E49.
  9. Remove the jumper from pins 1 and 2. Place the jumper over pin 2 only, in order to avoid losing it.
  10. Replace the access panel.
  11. Plug in the computer and turn on power. Allow the operating system to start. NOTE: Placing the jumper on pin 2 clears the current passwords and disables the password features.
  12. To re-enable the password features, repeat steps 1-3, then replace the jumper on pins 1 and 2.
  13. Repeat steps 5-6, then establish new passwords. Refer to the Computer Setup (F10 Setup) instructions to establish new passwords. *When the CMOS button is pushed or the jumper is removed, both the power-on password and the setup password become invalid because both are stored in the configuration memory. You will need to reset the passwords. Computer Setup (F10) Utility Features (not all
share|improve this answer
    
Forgot to mention that I already tried clearing the CMOS, and... nothing. –  silentw May 27 '13 at 16:20
    
you cleared using the jumper? –  Keltari May 27 '13 at 16:21
    
Will simply clearing the CMOS fix a failed/interrupted flash? Haven't ever seen this happen TBH, unless some sort of recovery/backup BIOS is present. But sure, nothing to be lost at this stage from trying. –  Karan May 27 '13 at 16:21
    
I cleared using the embedded button –  silentw May 27 '13 at 16:21
    
I would follow the steps. You have nothing to lose. –  Keltari May 27 '13 at 16:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.