Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My OpenWRT 10.03.1 Router (Linksys WRT160NL) is ignoring my crontab (set via System->Scheduled tasks). I want to reboot the router every night, since it tends to get flaky after some days. So I entered this in my tasks:

0 5 * * * reboot

I also tried

0 5 * * * root /sbin/reboot

but this was also ignored. Is there some kind of setting that I have to do, so that cron will be actually run? When I log into the router via ssh, and run ps, I don't see any cron process.

share|improve this question
up vote 6 down vote accepted

By default OpenWrt does not enable the cron service. To start it and enable automatic startup during subsequent reboots, you need to execute the following commands:

/etc/init.d/cron start
/etc/init.d/cron enable

The first command starts the cron service once, but does not change the startup configuration, so it will not be started automatically after a reboot. The second command changes the startup configuration (creates a symlink in /etc/rc.d) so that the cron service will be started during boot, but does not start it immediately.

share|improve this answer
    
This worked perfectly! – Arne May 27 '13 at 17:57
    
It seems odd to me that you would need to de this, yet in the Startup section of LUCI cron was/is listed as enabled with the rest of the items... (though it worked for me too) – Hayden Thring Feb 29 at 20:46
    
This confirms it though: wiki.openwrt.org/doc/howto/cron#activating_cron – Hayden Thring Feb 29 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .