Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I basically have a problem with Windows 7 connecting to my home network.

It keeps identifying my home network as unidentified, and it continually does "identifying" until it simply say cannot connect to the Internet. I don't know how this problem occurred. It simply happened one morning.

I am running Windows 7 Ultimate. I have a Realtek Network adapter. I don't think it's the drivers. I have already tried a system restore to a date when my computer was working fine, but it still didn't fix the problem. From what I've read online there was this bug in the services.msc area, something to do with Bonjour service. I cannot find either so I do not think that was the problem.

I'll be online for a while, so I can provide any additional details if needed.

I don't really know how to explain it, because it's so fudging complicated. I really appreciate clear and open steps to solving this. I have tried some things like system restore and rolling back drivers, and it doesn't seem to help.

share|improve this question
    
Bonjour is just a nuisance, err, network protocol that is installed automatically with iTunes (a media player made by Apple with great potential to thoroughly screw up any Windows box). if you don't need it, remove Bonjour via Programs and Features. –  Molly7244 Oct 24 '09 at 19:44
4  
Why was this made community wiki? Fail! –  Maxim Zaslavsky Nov 19 '09 at 23:18

9 Answers 9

I had this EXACT problem yesterday, to fix it try following these steps:

1) Go to the Control Panel, and open the "Device Manager"

2) Right click "Realtek RTL8168..." and click "Uninstall", it will prompt if you want to remove the driver, click yes (make sure to click YES, it will not work otherwise).

3) Restart Windows, and it will reinstall the stock Windows 7 driver for the card, your net should now be working.

share|improve this answer

This might still be a driver problem.

A driver from Realtek might be better than the default driver of Windows 7, so I suggest that you try to find your network adapter's driver on their site.

EDIT

A driver download is available here, version 7.006 dating from 2009/10/23 (yesterday).

Please compare this with your NIC's version this way : in Network Connections right-click your lan connection, choose Properties and then Configure.., and then the Driver tab to see the driver's details. Note these down somewhere.

Two versions are available, but I would pick "Win7 32/64 Auto Installation Program".
Click one of the GO buttons to download the zip file, then unpack it and see what's inside.

You can use Driver Magician Lite to save first the old driver, just in case.
Also create a system restore point before doing any manipulations.

share|improve this answer
    
The NIC's exact model is Realtek RTL8168/8111 Family PCI-E Gigabit Ethernet NIC (NDIS 6.0) –  Gordon Oct 24 '09 at 21:09

I fixed the problem (Realtek 8139 card) by disabling Bonjour. I would have to disable/enable the network connection after every boot until I stumbled upon this solution. Disable Bonjour; it is included with quite a few programs such as Itunes and Gizmo Phone. Type "services.msc" in a command prompt, find Bonjour in the list, and set it to disabled.

share|improve this answer

I experienced a similar issue on a friends PC and I have resolved the problem and I thought I'd share my findings. I tried the MAC address change and driver update to no avail. I also checked to see if Bonjour was running as a service but it wasnt. However it was Bonjour causing the problem and it was installed via Photoshop. Theres a bit about it on the Net if you look around and theres a utility to disable the Bonjour aspect of Photoshop without affecting Photoshop itself. Anyway, this fixed it so I thought I'd share the info.

Cheers.

share|improve this answer

It's all about ping-pong times. One of my friends advise following command to solve problem;

Type "services.msc" in a command prompt find "SSDP Discovery" and set as "Automatic".

Restart system..

That's all

share|improve this answer

I found this article on how to fix Windows 7 "Unidentified Network" issue. It works for me! http://knoxious.com/2010/04/28/windows-7-unidentified-network-fix/

share|improve this answer

Try this before messing with any drivers,

Run command prompt as administrator. Type the following: route print

If you see something similar to the following:

Network Destination - Netmask - Gateway - Interface - Metric

0.0.0.0 - 0.0.0.0 - On-link - [Your Network IP Address] - [A number (mine was 20)]

0.0.0.0 - 0.0.0.0 - [Your Network Gateway] - [Your Network IP Address] - [A number (also 20)]

Run this command:

route DELETE 0.0.0.0 MASK 0.0.0.0 0.0.0.0 if [Your interface number, found in the interface list under 'route print' (mine was 11)]

-

That should resolve any networking issues. Specifying routes can be very handy, but sometimes Windows screws it up like what was seen above.

share|improve this answer

I figured this out by talking to a friend at the local computer store. It's very simple to fix.

  1. Enter Device Manager and locate your Ethernet or wireless card
  2. Update the driver with a Windows Vista Driver - do not use the Windows 7 driver
  3. Reboot and enjoy
share|improve this answer

From Networking home computers running different versions of Windows:

If you're using another firewall, you must open these ports yourself so that your computer can find other computers and devices that have files or printers that you want to share.

share|improve this answer

protected by Ivo Flipse Jul 14 '10 at 20:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?