Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Visio 2010 I was able to enable glue to geometry with setting "developer tab → properties → glue settings" to 32 - visGlueToGeometry.

But in Visio 2013 it does not works. How can I enable it? I want to be able to connect to any point of shapes bounds.

share|improve this question
  1. Open Visio
  2. File -> Options -> Customize Ribbon
  4. Find and Add Snap & Glue...
  5. In Snap & Glue check GLUE TO -- SHAPE GEOMETRY


share|improve this answer
Have you tried it? It doesnot works for me. And as far as I know, setting properties is the same... – JleruOHeP Jun 5 '13 at 8:05
It did work for me. – itmilos Jun 5 '13 at 14:05
Hmm. What version of Visio do you use? – JleruOHeP Jun 6 '13 at 5:34
I am using trial version of Visio 2013 – itmilos Jun 6 '13 at 14:10

For 2013 Pro (should be the same for non-pro)

  1. In the ribbon you should see a "View" tab.
  2. In the view tab there is a section called "Visual Aids"
  3. There is a little icon you can click on to expand these options - click on this - et voila


  • Press Alt+F9 to get to the same place
share|improve this answer

After a lot of searching I found a potential solution. Instead of trying to enable snap to geometry, add a new connection point. It's not perfect, but it worked around the issue (for me, at least).

share|improve this answer
Unfortunately, it wont help me because adding a connection point will prevent from glueing to any other point except of connection one... – JleruOHeP Apr 14 '14 at 22:46

It depends on what is glued to what. It is not possible to really enable glue to geometry for connectors, they will always do as they see fit. Regular lines will snap to geometry correctly, but they're not as useful because they don't route around shapes.

Sadly, the connector tool has been improved to be more user friendly.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .