Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use SFTP to upload our website to our server with InMotion Hosting. It works fine when I am home and use our ISP (BellSouth.Net - Now AT&T. It also works fine on 1 of our Philippine ISP connection, but not on the 2nd connection we have at another building. It also fails when I am at a hotel on another ISP's connection.

I was told that hotels tend to close port 22 and that may be the issue, so we asked our Philippine ISP to open port 22, which they claimed they did, but it still would not connect. They claimed the 2 servers were now the same, yet one will allow us to connect, while the other cannot find the server.

I am suspecting that there also needs to be a SFTP daemon running, that will pass the connection request onto our host server.

Can anyone shed more light on this? I would be very much in appreciation.

share|improve this question
    
What error message are you getting? –  Martin Prikryl May 28 '13 at 9:47
    
You can run ssh -v USER@HOST while connected from each network, and compare the messages. –  Kent May 28 '13 at 23:44
    
Can you be a little more detailed with an example. Are you talking about using the cmd prompt? I tried that and the command prompt does not recognize ssh. I also tried using putty and found that I do not have to actually sign onto the server to test it. I only need to get a server response. i.e The server requesting "logon as:". When it does not work, I get nothing at all back from the server. It acts the same as when the IP is not in the firewall. Basically if the IP s not in the firewall, or the server is not available, you get the same response. They might have an issue with their DNS. –  Frank Aug 24 '13 at 22:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.