Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I hope this is the right place to ask this question. I had Windows 7 x64 on my HDD for a while before begin gifted an OCZ Agility 64Gb SSD as a boot drive and to hold often-used applications. Because I had a lot of data and programs on the HDD, I did not want to format, so I left it as is and set the SSD as the boot drive in BIOS. Now I have Windows 7 x64 ON BOTH DRIVES. Everything works fine once the computer is up and running (programs on the SSD are quick, those on the HDD run fine, etc.), but takes between 7 and 10 minutes to boot and up to 20 minutes to restart. I haven't worried too much about it because I don't turn my computer off THAT often, but I've been trying to figure it out for a few months and it's bugging me. Here's what I've done:

  • Made sure ATA controller was set at AHCI
  • Ran antivirus software and registry checker just in case
  • Went into msconfig and got rid of all non-essential boot programs/services
  • Ran Soluto, which was recommended on a StackOverflow question regarding boot times to see what is actually loading during boot.

While none of these have improved boot time, I noticed something very strange with the Soluto results: There are many Windows processes that take over 20 seconds EACH to load. A few of the longest:

System - 43.8 sec

  • Windows Explorer - 41.1 sec
  • Windows Session Manager - 33.7 sec
  • Windows Services Group (svchost) - 21.2 sec
  • etc...

I'm very confused by these results seeing as many people post sub-20 second boot times, so obviously something can't be right. The only thing I can think of is maybe the Windows install on the HDD is interfering with the boot/reboot? If that's the case, can I just uninstall Windows from that HDD and run the programs on it from the SSD? I'd hate to have to format it. If any one has any suggestion about where to look/what to do next, I'd really appreciate it. If you need any more information I'd be happy to provide. Thanks a lot.

Will

Update

  • I ran BCDEdit, and I was booting from the SSD.
  • When I was able to download and install the Windows SDK to use xbootmgr, it needed to reboot. Upon shutdown, it will not boot to anything (SSD, HDD, etc.), saying there is an unexpected problem communicating with a device connected to my computer. Status: 0xc00000e9. This has never happened in the past. The boot was slow, but always went through. I'm now using my wife's computer. I've tried unplugging the HDD, with the same error, unplugging the SSD and get a different error. Looks like I may be SOL now. Any ideas? I'll try to rebuild the BCD with Windows Recovery.
share|improve this question
    
You may wish to confirm (via BCDEdit, described here) that you're actually booting from the SSD. –  Aaron Miller May 28 '13 at 17:17
    
Have you ever defragged the SSD? If you haven't, don't! One of the most common reasons for this behavior is a result of defragging an SSD. SSDs aren't meant to be defragged, it reduces performance, and drastically reduces the life of an SSD. –  Ben Plont May 28 '13 at 17:27
    
capture a xbootmgr trace, zip and upload the trace and I'll take a look at it: ttp://www.msfn.org/board/index.php?showtopic=140247 –  magicandre1981 May 28 '13 at 17:57
    
If the HDD is disconnected does the PC boot from the SSD or do you get a missing bootmgr error? If it boots, is it faster without the HDD connected? Also, did you clone a Windows installation from an HDD to the SSD? –  Karan May 28 '13 at 18:33
    
the error code means this: STATUS_UNEXPECTED_IO_ERROR. Looks like a drive has a serious issue. Maybe the SATA controller has an issue. Try to connect it to a different SATA port. –  magicandre1981 May 29 '13 at 4:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.