Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Desktop PC (Windows XP) with two network adapters, one called "Local Network Area 2" and another one "Local Network Area 3".

The adapter marked as "Local Network Area 3" is connected to the office router to get internet and LAN connection.

The another adapter is for my RaspberryPi, which is connected via crossover cable. The problem that i have is that I can't connect to this mini-computer via SSH (using puTTY) using the crossover cable. I already tried changing the IP settings in this adapter, but i can't connect anyway because i don't know what IP (if any) is the raspberry getting. I also tried scanning IPs trying to detect it, but it doesn't appear. The OS running in RaspberryPi is Debian Linux (Raspbian).

What is the correct configuration that i have to do with the adapter?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

bridging the networks on your Windows PC will allow your Raspberry PI to connect (through your XP machine) and get an IP address from your DHCP server.

To do this click on one of the network connections e.g. "Local Network Area 2", hold down the Ctrl key and click on the 2nd connection "Local Network Area 3". Right click either connection and you will see an option to bridge the connections. Click this option and a new connection will be created.

You may need to reboot your Rasberry PI but it should get an IP address without issue.

Bridging connections is also useful to bridge to wireless networks, I use this type of connection to connect devices through my laptop rather than running a huge Ethernet cable to my router.

share|improve this answer
add comment

You need to set a static IP on the Raspberry Pi. If it's not getting an address from DHCP (I'm assuming neither the Raspberry Pi nor the PC are providing DHCP services) then it's probably using a link-local address (169.254.x.x). This is why it's not showing up in scans. Give it an IP address in the same subnet as your PC and you should be all set.

share|improve this answer
add comment

Bridge the two adapters, creating a single network that is awesome.

share|improve this answer
1  
That doesn't provide a lot of information to solve the issue. Any more to help answer the question? –  Brad Patton May 28 '13 at 23:29
    
This was hands down the best answer. NOTHING BUT THE BEST. –  Scandalist May 29 '13 at 20:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.