Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm analyzing boot times with systemd-analyze and, after optimizing it as far as I could, I noticed fsck-ing every partition on boot sometimes take up to 20 seconds. I feel it's unnecessary since I have never had problems and data on this computer is not vital.

Is there any way to stop this unneeded behavior?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I don't know if I missunderstand the question, this is realy simple and there alot of information on how to do this out there.

Anyway, disable fsck is quite simple and could be done in several ways, where I think fstab is the best way to do it permanent. Have a look at this link over at nixCraft, it's very straight forward. Basically change the last value to 0 in the device list in /etc/fstab for the devices that you want to change behavior on, that is. More information could also be found in the fstab manual (man fstab from the command line.)

share|improve this answer
    
The "fastboot" method does not work, but editing fstab has solved. –  ranisalt May 29 '13 at 23:56
    
Actually, it still does fsck on root directory, but at least it just fsck 50GB and not all the disk. –  ranisalt Jun 2 '13 at 6:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.