Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

nvtray.exe trying to connect to port
I have updated Nvidia GeForce GT 545 to driver version 320.18. Now every time i start my PC [Windows 7 64 Bit] i see in TCPView program that ntray.exe tries to connect all the time to the internet and fails. In the settings of GeForce Experience i turned off Automatic checking for updates & Notify me when updates are available. Also i set the Service Nvidia update service Daemon in services.msc on manual, so actually this should not be happening. The thing is that i don't want Nvidia to check for updates automatically but only when i want to. How can i solve this problem ?

It also bothers me how many Nvidia processes run on my PC. Do i need all of them to run ? Nvidia processes

share|improve this question
1  
try disabling the service. if the client starts running, and the service is stopped but startable, it probably tries to start it. –  Frank Thomas May 29 '13 at 11:33
    
this problem goes on and on till i start GeForce Experience which then starts the process daemonu.exe which then runs all the time on the PC. It seams that nvtray.exe is trying as you say to start daemonu.exe and it won't give up till it succeeds. I will try to set the service from manual to disabled, and report back. –  Devid May 29 '13 at 12:02
    
@FrankThomas i tried now and disabled it. The problem is the same, the process tries all the time to enable it but this should not happen actually. –  Devid May 29 '13 at 12:33
    
is the process actually doing anything, or just spin-wait? check the threads in Processexplorer. –  Frank Thomas May 29 '13 at 12:37
    
It is trying all the time to establish a connection. In Process Hacker i can see that it takes less than 0,01 CPU. That is all i can see it is doing –  Devid May 29 '13 at 13:06

2 Answers 2

up vote 1 down vote accepted

There is probably a bug in the latest version 320.18 of NVidia GEForce. Setting on manual the service NVIDIA Update Daemon will cause this problem. ntray.exe will then try all the time to start the update service. The only way stop this is to set all the NVIDIA services on manual. Maybe this will be corrected with the next update.

share|improve this answer

I had the same problem. If I just kill off the unneeded nvtray.exe, all is well.

(For me, all I have to do is click on it and it crashes. Problem solved!)

share|improve this answer
    
It is very annoying. It tries all the time to connect to the internet and check for new updates even though it is set from the options to not check for updates, also the nvidia service for updates is set to manual. It is very annoying that it is not doing what it is actually told to do. –  Devid Sep 12 '13 at 23:29
    
I think it's using a poor form of RPC to communicate with the underlying service. At least for me, the connections of interest are where nvtray.exe is connecting to something else on my computer, and not the internet. –  Brad Sep 13 '13 at 1:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.