Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to add some user controls to my toolbox, but every time I click "Choose Items" on the new tab I made, it crashes, no error messages, nothing. I lose all work as well.

Ever since I installed Visual Studio 2010 Beta 2, this has been happening!

How can I fix this, or at least find out WHY it crashed? I don't want to have to reinstall because it takes so long...

EDIT: Its been 6 days and still no change. I cannot even add the controls that I made...

EDIT: Several months later, no improvement. I have reinstalled and uninstalled vb express, reset the toolbox, nothing. Its express, so I can't use the workaround...

share|improve this question
    
Visual Studio betas shouldn't be installed on production machines without a backup plan. When I try a beta, I'll either use a virtual machine, or I'll make a backup before I proceed if I'm installing the beta natively. –  Chris W. Rea Oct 31 '09 at 1:28
    
After 6 days I'd be questioning whether a reinstall really takes too long. –  Michael Itzoe Feb 22 '10 at 22:20
    
Reinstall has done nothing, still crashes EVERY time without fail, I have no way to add things... –  Cyclone Mar 1 '10 at 1:21

3 Answers 3

This is a known bug of Visual Studio. The simple solution is to start Visual Studio in safemode, which will stop it from crashing and reporting the exception instead.

C:\yourPathToVisualStudio\devenv.exe /safemode
share|improve this answer
    
Sorry for the late reply, but is there any way to change my shortcut target to launch in safemode? "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\vbexpress.exe /safemode" does not work for me, clearly. –  Cyclone Feb 28 '10 at 22:40
    
Also, I don't have this "devenv.exe" file, I am in express..... –  Cyclone Mar 1 '10 at 0:59
1  
You have to pass the arguements outside of the path quotes. E.G. "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\vbexpress.exe" /safemode otherwise the shell tries to interpret them as part of the path, and you get a "Cannot Find" error. Also, "devenv.exe" is the executable for the full visual studio, rather than the express version. –  Fake Name Mar 1 '10 at 4:10

Try installing/reinstalling visual studio service pack, looks like something got unregistered or an operation did not complete when you installed the beta.

share|improve this answer
    
Running a reinstall, hopefully this should fix it. I really want to add some new stuff to the toolbox, and even if it loads very slowly, thats better than nothing at all. –  Cyclone Feb 28 '10 at 23:57
    
Did not work... –  Cyclone Mar 1 '10 at 1:06
    
I even tried resetting the toolbox, new settings, etc. –  Cyclone Mar 1 '10 at 1:22
up vote 0 down vote accepted

I had a sudden moment of inspiration. I uninstalled VS 2010 Beta 2, and lo, and behold! it worked! Something that vs did completely broke my ability to use that item.

I'm very glad to have this working again, and thanks for the tips.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.