Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm getting an error while trying to update my Google Chrome in RHEL6.

[alexus@wcmisdlin02 ~]$ sudo yum update
[sudo] password for alexus: 
Loaded plugins: refresh-packagekit, security
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-beta.x86_64 0:27.0.1453.93-200836 will be updated
---> Package google-chrome-beta.x86_64 0:28.0.1500.20-201172 will be an update
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: google-chrome-beta-28.0.1500.20-201172.x86_64
--> Finished Dependency Resolution
Error: Package: google-chrome-beta-28.0.1500.20-201172.x86_64 (google-chrome)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[alexus@wcmisdlin02 ~]$ cat /etc/redhat-release 
Scientific Linux release 6.4 (Carbon)
[alexus@wcmisdlin02 ~]$ uname -a
Linux wcmisdlin02.uftmasterad.org 2.6.32-358.6.2.el6.x86_64 #1 SMP Thu May 16 11:21:38 CDT 2013 x86_64 x86_64 x86_64 GNU/Linux
[alexus@wcmisdlin02 ~]$ 

I found following article(s):

Is there anything can be done to move to v28 on RHEL6? (other then wait for RHEL7)?

share|improve this question
    
I assumed you tried --skip-broken? I should add that Chrome stop supporting FHEL6 since Release 27 In the end the likely hood is that Google has migrated their standard library and you are simply out of luck. –  Ramhound May 29 '13 at 16:08
    
no point of trying --skip-broken as it will skip the only one package "google-chrome-beta". I'm sure what I'm saying is (nearly) impossible but who knows, maybe someone will find a way to get it going somehow) –  alexus May 29 '13 at 16:17
    
Perhaps you could switch to Chromium and compile from source? Not ideal, I understand, but essentially the same browser and would get you there. –  nerdwaller May 29 '13 at 17:29
    
@alexus - I am not familar with the command was trying to suggest the least path of resistance. Anyways Google has migrated from the old standard library so there isn't much you can unless your able to replace the std library used by RHEL6 yourself. –  Ramhound May 29 '13 at 20:28

3 Answers 3

up vote 1 down vote accepted

Also try the script here:

http://chrome.richardlloyd.org.uk/

It downloads/installs the latest Chrome plus various libraries extracted from downloaded Fedora 15 RPMs. It's allowed me to run Chrome 28 on my 64-bit CentOS 6.4 system successfully.

share|improve this answer

my understanding is that it is a gcc version issue/requirement upcoming versions of chrome is setting. you can try upgrading gcc to version 4.7.0. I personally haven't tried it since my rhel6 machine is locked at the version it has do to project requirements, but if you get it working I'd like to know so that I can update once I finish this current project.

share|improve this answer

You can try installing an old version as described in this post: http://georgeinenglish.com/solved-google-chrome-no-longer-installs-on-centos-6-4/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.