Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm very used to having Emacs interpret M-left/M-right as backword/forwards word. However, last night, for some reason, Emacs started interpreting M-left as D and M-right as C.

I'm wondering how I can restore the default behavior. I haven't changed my .emacs file at all, and I'm using iTerm, with the option key set as meta.

Any help will be appreciated.

Thanks!

--Edit--

I've figured out that the problem is with iTerm and not Emacs. Emacs interprets the commands correctly in the built-in terminal, but not in emacs.

share|improve this question
    
", but not in iTerm"? – Chad Skeeters Jul 15 '13 at 23:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.