Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

EDIT: was able to fix this by logging in with another account in the same group, and accessing it that way. It only worked because I was lucky enough to have that other account in the same group though. I'd still like to know if there's another way around this issue.

hmm...

i meant to do

> chmod 755 <directory>

but I typed

> chmod 75 <directory>

which results in

> d---rwxr-x   5 justin        512 Oct 24 19:35 gallery

I own the directory, but can't access it.

I don't have root.

What to do...

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You've managed to give the group owner full access (assuming there is one; your ls output doesn't indicate one). If there is a group owner, say, group foo, you could log in to the group with newgrp:

$ newgrp foo

This might allow you to issue the corrective chmod 755 <directory>.

You could also try to recursively chmod the parent directory, if you own it. Be careful to record permissions on other subdirectories and files so you can restore them properly later.

Barring either of those solutions, you'll have to contact the system administrator to fix it for you. Some breakages just require root to fix.

share|improve this answer
    
was able to fix this by logging in with another account (just happen to have 2 accounts) with membership in the same group as the directory, and issuing the chmod that way, restoring owner permissions. It's weird how that worked out, but it makes sense; permissions are matched from left to right, and the first match "wins". Thanks all for the help. –  Justin Nov 11 '09 at 6:23

You should be able to do:

chmod 755 <directory>

If that does not work, running it as root will work:

sudo chmod 755 <directory>
share|improve this answer
    
Neither works, unfortunately, because I have no access to the directory, and don't have root access. But I own the directory. It's crazy. –  Justin Oct 25 '09 at 0:03
    
I tried these on my system (Linux, GNU coreutils), and they worked. Perhaps it would be good to specify exactly what unix you're using. –  Ryan Thompson Oct 25 '09 at 0:10
1  
Mac OS X, actually. I think it was an issue with groups. Once I chgrp'd it, I was able to remove it. Thanks for the quick replies. –  Justin Oct 25 '09 at 0:14
    
you should set that as an answer then. –  quack quixote Oct 25 '09 at 0:18
    
Definitely add chgrp as an answer! Maybe my answer will work for other people. I'm sorry it didn't work for you, but I'm very happy you seem to have solved your problem. –  ChrisInEdmonton Oct 25 '09 at 6:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.