Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of the partitions on an external drive just went partway south on me. It shows up grayed out (unmounted) in Disk Utility as "disk3s5" but DU won't mount it. I ran the following:

localhost:~ tod$ diskutil mountDisk /dev/disk3s5 

One or more volume(s) failed to mount

As you can see, however, the command failed. Interestingly, in the list output by diskutil list, it shows up without a name.

I've used Disk Warrior and Drive Genius, and neither of them fixed the partition.

Any tips on how to get this dog to mount so I can move files elsewhere?

share|improve this question
    
What file system you have got on this partition? –  Chris May 29 '13 at 19:55
    
Might want to see if you can use TestDisk to browse the files or repair the filesystem... –  Breakthrough May 29 '13 at 20:07
    
Sorry Folks, I totally forgot to add crucial details. I'm using a late 2012 Mac Mini running OS X 10.8.3. The file system is HFS. There are several other partitions on this 2TB drive and all of them mound and unmount fine. Can read/write to all of them. Doing a "Repair Disk" within Disk Utility returns such wonderful error messages as "Invalid B-tree node size" and "Error: Disk Utility can't repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files." Trouble is, I can't back them up until I've mounted it. :-( –  Jack Daniels May 29 '13 at 21:17
    
Anything in your /etc/fstab file? That caused this issue for me. –  Xeoncross Sep 6 at 16:50

1 Answer 1

Well, before doing any work on this partition you should have done an image in RO mode and work on the image. I'm not sure if there is much what can be done now without actually seeing the disk.

Try non-destructive tools (haha! dodn't exist really!). Some people had good resouls with SpinRite: https://www.grc.com/spinrite.htm

PartedMagic - PC, http://partedmagic.com/doku.php -comes with many recovery tools but really you need to know how to use them...

share|improve this answer
    
@ Chris: Thanks for the tips and the disheartening news about my chances! –  Jack Daniels May 30 '13 at 18:09
    
@ Breakthrough: Thanks for the suggestion. I've been running TestDisk for nearly 24 hours and it's at some point in its analysis. it's checking "cylinders" and has gotten through 813 million of them, out of 3.9 trillion - some 20%. At this rate it will be another few days... Then when that test is concluded, I have no idea what it will tell me or what TD can then do to recover anything. With my run of luck, it will probably print a message that essentially says, "Tough Sh*t, Sherlock!" –  Jack Daniels May 30 '13 at 18:14
    
Backup. Keep the backup of everything important. I haven't used TestDisk myself but I would recommend - as stated before - SpinRite. I've heard good things about alsoft.com/diskwarrior - but I haven't used it myself. You probably need to rebuild directories and probably you will have bad blocks. What is SMART telling you? –  Chris May 30 '13 at 18:20
    
Followup thoughts: Since I've worried a few fingernails down to the quick trying to recall exactly what was filed in that partition, I'm ready to accept that whatever was there is now gone forever unless I want to spend big bucks and lots of time sending this to a "drive saver" outfit. All I know is that it didn't contain anything valuable. This is a fairly new drive where I probably stored some odds and ends temporarily. My primary boot/working drive is backed up five ways from Sunday. –  Jack Daniels May 30 '13 at 18:21
    
@ Chris: Backup Yes indeed. Been doing that since the dark ages. See my note above. I tried DiskWarrior, no luck. Unfortunately when I check the System Info on the drive, it says that SMART is not supported, which is odd in itself. It's a new Newer MiniStack Max connected by FW 800 directly to my Mac Mini. I'll download and try SpinRite later as a last resort. Thanks again for following this thread. –  Jack Daniels May 30 '13 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.