Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I try to put a micro-SD card into the slot on my Surface RT, the card does not show up at all. I don't even get an acknowledgement that some device was inserted (other than the usual sounds). When I look it up in Device Manager, it says that the device is not working properly. What is the problem?

share|improve this question
What type of card (manufacturer, model i.e. SDHC/SDXC/..., class, size etc.) is it? Have you tried more than one card? Are you sure it's not a hardware issue, because I haven't faced any such problem. – Karan May 30 '13 at 21:20
@Karan It happens with all my cards, which are both SD and SDHC (the slot is not compatible with SDXC). – gparyani May 30 '13 at 21:40
The Surface RT definitely does have a microSDXC card slot (see the Ports section of the FAQ). I'm using a 64GB Class 10 SanDisk microSDXC card myself. – Karan May 30 '13 at 21:53
@Karan Oh, it does. But if SD and SDHC cards don't work, then SDXC cards should probably not work either... – gparyani May 31 '13 at 0:53
Yes, which is why it sounds to me like a hardware issue in your case. – Karan May 31 '13 at 0:53
up vote 1 down vote accepted

Thanks @Karan for your help. I contacted Microsoft Support and thay had me run the hardware troubleshooter, which fixed the problem.

share|improve this answer
So it was a software/driver issue after all? Must be a relief for you. :) (Also, @ notification works only for comments, not in answers.) – Karan May 31 '13 at 4:42
@Karan I'm a Stack Overflow user too, so I know. I just wanted you to see this answer. – gparyani May 31 '13 at 4:46
Thanks, but I only saw it because your answer pushed it to the top of the Active list. Anyway, I wonder what exactly was fixed. Does anyone know where the Windows Hardware Troubleshooter logs its actions? – Karan May 31 '13 at 4:48
@Karan It just spontaneously fixed after I ran the troubleshooter. The troubleshooter, however, did not report any problems. – gparyani May 31 '13 at 4:49
"Curiouser and curiouser!" cried Alice. – Karan May 31 '13 at 4:52

I have the same problem. I solved mine my putting two pieces of tape on the side of the SD card opposite the contacts and reinsert the sd card. The problem seems to be the card receptacle and with the tape opposite the contacts it forces the card against the contacts inside the RT. Try pushing the card in with your finger prior to adding tape and holding it for a while and you will probably see the card show up in file manager.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .