Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was trying to install PostgreSQL 9.2 in Windows 7. When I launched the installer, it failed and showed the error message:

Unable to write inside TEMP environment variable path

I did a lot of research. I tried almost all methods but none of them works. Finally I came across this post.

I can see my HKEY_LOCAL_MACHINE->SOFTWARE->Classes->CLSID->B54F3741-5B07-11cf-A4B0-00AA004A55E8} -> InprocServer32 is NOT C:\Windows\System32\vbscript.dll. It is incorrectly set to C:\Program Files\Common Files\McAfee\SystemCore\ScriptSn.20120815030544.dll. Actually I don't have McAfee installed on my machine.

But when I tried modifying this key, Windows regedit doesn't allow me to change this key.

So what can I do to resolve this problem?

share|improve this question

migrated from stackoverflow.com May 30 '13 at 6:39

This question came from our site for professional and enthusiast programmers.

    
You need to run your installer as an administrator. (Right-click the installer, and choose Run as administrator from the context menu.) Adminstrative privileges are required to write to HKLM on Vista and higher (or XP when not running as a power user or local administrator). Software installation isn't really a programming question; this is more suited for Super User instead of StackOverflow. –  Ken White May 30 '13 at 1:52
    
I tried running PostgreSQL installer in administrator mode but the same error happened. I guess it is due to the incorrect Registry key. So how to run the regedit in administrator mode in Win 7 so that I can change that key? –  tonga May 30 '13 at 1:57
    
Start it from an adminstrator command prompt. (Click the Start button and type Command in the search box. When Command Prompt appears at the top of the menu, right-click it and choose Run as administrator. Once that command prompt appears, type regedit and hit Enter.) Once again, not a programming question. :-) –  Ken White May 30 '13 at 2:01
    
Thanks Ken. I ran the regedit in administrator mode and tried modifying that key but it still doesn't allow me to change that key. The error says: "Cannot edit: error writing the value's new contents". Any idea to solve this? –  tonga May 30 '13 at 2:05
1  
Sorry, no. It appears you do have some AV or malware prevention software, or you have other issues with your system. However, for the third time, this is not a programming question and is off topic here. We're now in the area of general computer support (not even software installation). Ask a question at Super User about this issue and how to solve it. :-) –  Ken White May 30 '13 at 2:09

1 Answer 1

See this link, and you can change the HKEY_LOCAL_MACHINE->SOFTWARE->Classes->CLSID->B54F3741-5B07-11cf-A4B0-00AA004A55E8} -> InprocServer32

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.