Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a really strange problem with a Windows 7 SP1 machine. All of the USB devices (except the mouse and an external USB audio card) are not working. I've got no clue what the hell is wrong with the OS. All USB flash devices are recognized but are not mounted and in the Device Manager they show up with an exclamation mark stating there is something wrong with the drivers. They're not showning in Disk Manager as well.

The devices and usb ports are working fine - I've tried to mount all of the USB flash pens I had on all ports of the same machine under Slackware and everything worked just fine. So I've ruled that one out as well.

So far I've tried:

  1. Uninstalling the device from Device Manager, rebooting, inserting the USB again; result: Failed to install driver.
  2. Installing all updates from the Update center
  3. Running Multi Byte Malware and Avira to scan for any viruses - nothing found (pretty much the machine is used for development of web sites and android applications with licensed applications so having viruses is quite unlikely)
  4. A couple of Fix me programs from Microsoft support center but none of them fixed anything.

I would really, REALLY appreciate any ideas - what so ever! This is quite irritating and I'm out of ideas...

share|improve this question
1  
First try running USB Oblivion with the "real clean" checkbox checked. If that doesn't help, uninstall all USB host controllers and root hubs from Device Manager, reboot, and see if it helped. –  Karan May 31 '13 at 4:21
    
Thank you for your suggestion! Unfortunately it did not work. I tried reinstalling the usb controllers again. Whatever I do, the usb flash devices do not get recognized. After I ran USB Oblivion, though, my other devices started working (a usb printer and a phone connected via usb) –  tftd May 31 '13 at 14:06

1 Answer 1

Have you considered reinstalling Windows 7 completely? I had a similar problem in the past (some usb ports worked intermittently) and after some time spend I just decided to format the laptop and reinstall Windows 7. It worked and never had issues after.

The last resort is to completely update the motherboard drivers or uninstall and reinstall them.

share|improve this answer
1  
I know I can reinstall, but I would like to fix the problem without reinstalling - I have a lot of developer software installed and it would take me 2 days to reconfigure everything again. But if nothing else helps I guess that's the only step I could take. –  tftd May 31 '13 at 13:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.