Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a cheap e-Machines laptop - a D620 - running ubuntu 8.10. I'm using Gnome and have installed very little beyond the defaults. For some reason, no movies play on my computer at all. They start, but after the movie player appears initially, it just exits. Same results with mpeg & avi. Sometimes I get audio while it's playing, but no picture.

Initially I thought the problem was with Totem, I have tried VLC and mplayer, nothing works. Any advice on how to even begin troubleshooting this would be appreciated.

Carls idea to run the movie player in Terminal was great! I didn't know you could do that. When I googled that error I found out that I could run mplayer with extra arguments line this: mplayer -vo x11 -zoom -framedrop file.avi

This worked perfectly, & all my movies play with mplayer.

share|improve this question
    
It never prompts you about codecs missing or anything like that? –  Matthew Talbert Oct 25 '09 at 4:03
    
VLC at least should work without codecs... –  quack quixote Oct 25 '09 at 5:45

1 Answer 1

up vote 2 down vote accepted

Run any given player from the Terminal, and see whether you get a useful error message when the program exits. Try this with all of them, and edit your question to show the messages.

If you get nothing useful, try running VLC or one of the others inside strace, and see if there are any missing libraries.

Is fglrx installed? Check in synaptic, or post the output of "dpkg --get-selections | grep fglvrx". As an alternative you could try the radeonhd driver.

share|improve this answer
    
I think this worked. Both vlc and mplayer wrote a ton of junk to the terminal, but they both printed out exactly the same thing on 1 line: 'X Error of failed request: BadAlloc (insufficient resources for operation), so I think maybe I don't have enough memory? Might you know what other resources would be requires? –  Nina Oct 25 '09 at 14:26
    
The message you list is almost certainly a bug in the driver for your video chipset. Again, are you using fglvrx or radeonhd? Whichever you're using, try the other. (I don't actually know that you have the Radeon chipset, but that's what the eMachines site leads me to think. It would be good to post the output of "dpkg --get-selections | grep fglvrx" and perhaps "lspci". –  CarlF Oct 25 '09 at 23:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.