Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problems ssh to my own box (both remotely or locally) with the message

Permission denied, please try again.

Then I stop the sshd service with /etc/init.d/sshd stop and start sshd in debug mode /usr/sbin/sshd -d. I can connect this time, both remotely or locally works.

I cannot figure out what's the difference between these two situations. Any hints will be highly appreciated. Thank you and best regards!

share|improve this question
    
The title of your post needs to be a question. How about "Why is SSH permission denied unless sshd is in debug mode?" –  Mike Brown May 31 '13 at 4:40
    
@MikeBrown Thanks. Updated already. –  Summer_More_More_Tea May 31 '13 at 5:24
    
which disto are you using, and copy how you try your login ssh ...</br> If you are trying to log in ar root@server it won't let you –  mirkobrankovic May 31 '13 at 8:40

2 Answers 2

Do you have a password set for your user? If not, you may have to either set a password or use key-based ssh authentication.

share|improve this answer
    
Thank you for your response. I do have a password set for my account. :) –  Summer_More_More_Tea May 31 '13 at 4:31

I had the same problem. Disabling SELinux solved it for me.

You can try to temporary disable SELinux:

echo 0 >/selinux/enforce

or permanent:

#/etc/selinux/config
SELINUX=disabled
share|improve this answer
    
Ehm, this is NOT something you want to do with the possible exception as to debugging the problem. It is akin to "My lock is rusty. Lets solve it by jamming the front door open". –  Hennes Jul 23 '13 at 13:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.