Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

usually AltGr Works fine on my computer but latelly it stops working. I can still use Ctrl+Alt but it's a pain as I need it to write {} and I'm a c# programmer :S

Any idea on what can happen? If I reboot the laptop everything Works fine. It's not a failure of the key itself becasue when I press it the menus get the _ drawn, so the keyboard is sending the message to the OS.

Thanks in advance.

share|improve this question
    
What's your keyboard layout? Do you have any other layouts enabled? –  gronostaj May 31 '13 at 10:24
    
I already checked the layout and it's ok. I have two layouts but almost always I use just one. The issue has stopped a few minutes ago without restarting, It has come and gone. –  SoMoS May 31 '13 at 11:50
    
You say computer, I assume laptop, because my first test would be replacing it.. but somehow I have the feeling you lack that choice. –  NickW Jun 12 '13 at 15:06
1  
I'd try swapping keyboards, just to be sure. Just as an aside, it isn't a bluetooth keyboard is it? I've had issues with interference make my keyboard do very strange things. –  NickW Jun 12 '13 at 15:11
1  
This happens to me too, randomly stops working, I used to have another language installed but this still happens after i removed the language, sometimes a restart fixes it and another times it fixes its self. –  Juan Zamudio Jul 9 '13 at 17:55

4 Answers 4

There are may blog posts out there, which try to explain what the issue could be. Many times specific programms are the cause of the problem.

For me it was the Windows Remote Desktop that prevented the key from working. I didn't had to close it, just clicking at it and somehow my [AltGR] key works again!

EDIT: It seems to the related to the full-screen mode of RDP. See this KB article.

Just try to close all your applications one by one to find out what could be the cause.

share|improve this answer
    
Maybe I had a WRD active ... I don't remember. I'll check this the next time. Thanks! –  SoMoS Jul 10 '13 at 11:53
5  
Works for me after closing all RDP sessions, thanks. –  Ezombort Jul 18 '13 at 12:34
    
I had a remote desktop session running fullscreen on other monitor and that was causing the issue. Minimizing the remote desktop window was enough to solve the issue. The problem does not occur always when remote desktop is fullscreen. –  Juha Palomäki Oct 24 '13 at 2:58
    
It just happened to me (Winows 7). I noticed it in Eclipse, but it did not work in other programs either (like the system Run... dialog). I had a RDP window running, so I clicked inside it, tried to type to the remote system and now AltGr worked. Then I went back to a local program in there it worked too. Bizzare... –  David Balažic Jan 16 at 19:12
2  
Worked for me. Really crazy, but at least for me it was enough to click on the remote desktop window and then click an open program in the remote desktop. After that it worked again everywhere, without rebooting or closing anything. –  Juha Untinen Jul 8 at 7:19

Here it turned out to be a running VirtualBox-instance that had tampered with my keyboard setup. After shifting focus to the VM and back to the editor the AltGr-key worked as expected.

I'm running Windows 7 SP1, so AltGr acting as Alt is a problem not only on Windows 8.

share|improve this answer
    
It was the cause of my problem too. As I use the VM to run a debian server, I turned off the GUI like stated there: without-brains.net/blog/2011/05/06/… it also increased performence a little bit. –  Salketer Jan 16 at 8:41
    
Me too. Annoying how a user mode application (with half a dozen drivers, no doubt) messes up something as essential as users keyboard layout, without Windows even suspecting it or issuing a warning to the user of said layout. –  amn Feb 14 at 12:35

For me, it was caused by Hyper-V (Microsoft virtualization). When I go to virtual machine, press AltGr it works. Return to desktop, works again!

share|improve this answer
    
I had the same issue and focusing to Windows Phone emulator running in the background fixed it. –  juarola Dec 21 '13 at 0:54

The questioner have a laptop, so this is not probably answer for him/her. But nevertheless:

One possible reason of AltGr problems is Gigabyte EasyTune. It adds some own shortcuts to keyboard (or something else), which causes the problem.

Atleast with nordic keyboard maps: it causes problems with '@' [AltGr+2] and '€' [AltGr+5].

With Win8.1 solution was: uninstalling of EasyTune.

share|improve this answer

protected by Community Apr 23 at 23:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.