Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In LibreOffice, I'm entering some text into cells, which happens to look like a math problem:

-5 / -10 / -15

The program assumes I want to calculate this, and sticks an equals sign automatically in the front of the cell contents for me:

=-5 / -10 / -15

I've looked all over the options and autocorrect-options pages, but I cannot seem to find a way to disable this behaviour. Short of sticking it in quotes, like "-5 / -10 / -15", is there a way to stop the program from automatically adding the equals sign?

share|improve this question
up vote 4 down vote accepted

I just tried this by right-clicking the cell and setting the format as "Text" before entering anything. That has kept the text exactly as I entered it.

LibreOffice Calc Text format

share|improve this answer

Just prepend your text with an apostrophe ' like this:

'-5 / -10 / -15

Libreoffice will drop that first character, and consider everything after that as just string of text.

share|improve this answer
    
This is great if you're just working with numbers, try inputting '-x +6 and you'll notice that the apostrophe remains, unlike when handling numbers. FYI, my Calc replaces the expression -x +6 as =-'x'+6 for some stupid reason – hanzo2001 Aug 6 '15 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .