Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The setup:

  • Windows 7 laptop, IP: 192.168.0.107
  • Windows 2000 desktop, IP: 192.168.0.100
  • D-link wireless router, IP: 192.168.0.10

I have set the laptop to pick IP settings from the router through DHCP. When the laptop connects to the network it gets assigned 192.168.0.10 as the Default Gateway. This is ok and I can use the internet normally.

Some time over the course of the day, the Default Gateway IP setting changes to 192.168.0.100. I do not detect this since the desktop computer at that time is on and I have no issues using thte internet. However, when the desktop computer is switched off at the end of the day, my internet connection disappears and that's when I realize that it was using the desktop's IP as the gateway address.

To get the setting back to the correct IP, I disable and re-enable the wireless adapter. What I can't seem to figure out is why this setting changes at all. Is it a malware issue? Is Windows 7 known to mysteriously change the Default Gateway setting?

UPDATE 2013-08-19

I'm not sure why the question got a down-vote since I believe it is a valid and troubling issue.

The automatic Gateway IP change did not go away. The only DHCP server on the network is the router. I even tried monitoring the IP change to figure out what exatly could be initiating it, but didn't manage to get to the bottom of it. In the end I simply removed Windows 2000 from the PC and set up XP instead. The weird behavior is gone.

share|improve this question
    
After you notice it's changed, what address does ipconfig /all report as the DHCP server for that connection? –  Ƭᴇcʜιᴇ007 May 31 '13 at 20:48

1 Answer 1

It looks like your Desktop PC is running DHCP or ICS (Internet Connection Sharing). You should have only one DHCP server on your network.

EDIT: To disable DHCP on Win 2000:

Go to the "Services Console" in the "Admin Tools" folder and then double click the DHCP Server and select Disabled. Click OK and job done!

share|improve this answer
    
The DHCP service was not enabled on the Win2K computer. I blocked any connections from it on the Win7 laptop firewall to see whether that solves it. Seemed to work for a few days, but it's happened again. Is there a way to moniter the Gateway IP change event so that I can at least know where it's being initiated from? –  KalenGi Jun 9 '13 at 13:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.