Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed debian (wheezy) on my laptop. Previous OS was ubuntu. I get a beep each time I plug in my (wired) USB mouse and every time I move it. An older wired USB mouse does not have this problem, I can plug it in and move it with no beeping. I also get no beeping when plugging in other USB devices (I tried with a camera).

How can I stop this?

This is the output of dmesg | tail after plugging the mouse in:

[ 7720.353311] usb 4-1.1: USB disconnect, device number 26
[ 7725.670394] usb 4-1.1: new low-speed USB device number 27 using ehci_hcd
[ 7725.768030] usb 4-1.1: New USB device found, idVendor=09da, idProduct=000a
[ 7725.768037] usb 4-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 7725.768041] usb 4-1.1: Product: USB Mouse
[ 7725.768044] usb 4-1.1: Manufacturer: A4Tech
[ 7725.771411] input: A4Tech USB Mouse as /devices/pci0000:00/0000:00:1d.0/usb4/4-1/4-1.1/4-1.1:1.0/input/input31
[ 7725.771844] a4tech 0003:09DA:000A.0013: input,hidraw0: USB HID v1.10 Mouse [A4Tech USB Mouse] on usb-0000:00:1d.0-1.1/input0
[ 7728.257145] uvcvideo: Failed to set UVC commit control : -71 (exp. 26).
[ 7728.257160] uvcvideo 1-1.2:1.1: resume error -5


Beeping mouse model is: A4Tech X6-6AK. GLaser.

share|improve this question
>Is the sound coming from the mouse or from the headphone? - My mouse is very quit and peaceful. It doesn't move by itself only with my help. It does not bite. :) Sound is coming only from headphones. Laptop speakers keep silence. – webprogrammer Jun 1 '13 at 20:42
So one wired mouse causes beeps but another wired mouse does not? Connect the mouse that causes beeps and connect a different headphone and see if it stops. What's the mouse? Did you try a different USB port? – sammyg Jun 1 '13 at 20:46
I tried different USB-ports but no results. I can't find another headphones yet. – webprogrammer Jun 1 '13 at 20:51
This also can be a symptom of having a broken wire in the mouse cable. The disconnect/reconnect beep is caused as the mouse electronics drop offline and get redetected. – Fiasco Labs Jan 18 '15 at 18:14

The fact that you only get this problem with a specific mouse probably means that your system has a problem with that mouse only. We can't really help unless we know the exact model.

A possible workaround would be to disable all beeps (which I do anyway). Depending on which module is used for the beep one of these should remove it:

  1. Blacklist the pcspkr module.

    First find out if it is loaded and if it is causing the problem:

    lsmod | grep pcspkr

    If that command returns nothing, then try one of the other options. If the command does return something, the module is loaded. Try unloading it and then moving the mouse, do you still get the beeps?

    sudo rmmod pcspkr

    If that stops the beeps, you can stop pcspkr from being loaded by adding it to /etc/modprobe.d/blacklist:

    echo "blacklist pcspkr" | sudo tee -a /etc/modprobe.d/blacklist
  2. Mute the beep in alsamixer:

    enter image description here

  3. If you are using the snd_hda_intel module, add this line to /etc/modprobe.d/alsa-base.conf:

    options snd_hda_intel beep_mode=0


share|improve this answer
I added mouse model at end of the question. – webprogrammer Jun 1 '13 at 20:57
> lsmod | grep pcspkr --- return "pcspkr 12579 0 " – webprogrammer Jun 1 '13 at 21:00
>sudo rmmod pcspkr --- did not stop the beeping. – webprogrammer Jun 1 '13 at 21:01
@webprogrammer we try to minimize comments on the SE sites, please post just a single comment with what you want to say and don't break it into many small ones. – terdon Jun 1 '13 at 21:02
ok, I will try but I don't know how to add new line to my comment. Neither "Enter" nor "Ctrl+Entrl" not working as I was expected. --- I have not installed "alsamixer". In my "/etc/modprobe.d/" there are 2 files: "fbdev-blacklist.conf" and "radeon-kms.conf" should I create new file "alsa-base.conf"? – webprogrammer Jun 1 '13 at 21:08

Plugging my USB mouse into a rear USB port instead of into a front port (close to my headphone jacks) solved this problem for me.

share|improve this answer
Unfortunately, this doesn't answer the question. If you'd like to ask a new question, click on the Ask Question button at the top of the page and enter your question. This area is for answers, so your post will likely be deleted shortly. – boboes Jan 18 '15 at 18:30
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. – MaQleod Jan 18 '15 at 18:45
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – DavidPostill Jan 18 '15 at 21:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.